aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-04 19:46:46 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-06 20:38:40 -0700
commit8cc64128c70c5b6a41b050332abb1d73a10ef4fa (patch)
treeb1a21a41f7842d2fb250fba5474ee1fb0f52dd77
parent332e3fc477ffcfcf0af0fa3171e53428b8ac083c (diff)
downloadmeta-openembedded-contrib-8cc64128c70c5b6a41b050332abb1d73a10ef4fa.tar.gz
fvwm: Fix build time paths in target perl/python scripts
Add rdeps as needed Fixes shebang-size QA warnings Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
index 54e0a0ef4d..e0449269c0 100644
--- a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
+++ b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.9.bb
@@ -82,6 +82,9 @@ do_install:append() {
install -d -m 0755 ${D}/${datadir}/fvwm
touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${bindir}/fvwm-*
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/perl-native/perl:${USRBINPATH}/env perl:g' ${D}${libexecdir}/fvwm/*/Fvwm*
+ sed -i -e 's:${STAGING_BINDIR_NATIVE}/python3-native/python3:${USRBINPATH}/env python3:g' ${D}${bindir}/fvwm-menu-desktop
}
# the only needed packages (note: locale packages are automatically generated
@@ -112,3 +115,7 @@ FILES:${PN}-doc = " \
RDEPENDS:${PN} = " \
xuser-account \
"
+RDEPENDS:${PN}-extra += "\
+ perl \
+ python3-core \
+"