aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-25 14:23:21 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-28 20:49:15 -0700
commit80efddfabbee4cc18e33e40ec61ad1ff47b47a6c (patch)
treee3a8fdd086313fb0e8d810aa2fe74c75ff3e8ae9
parent07843a418b974963e9b2f6d90227433fdc463cd1 (diff)
downloadmeta-openembedded-contrib-80efddfabbee4cc18e33e40ec61ad1ff47b47a6c.tar.gz
python3-pycrypto: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-pycrypto.inc21
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch (renamed from meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch (renamed from meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch)0
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb24
4 files changed, 21 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto.inc b/meta-python/recipes-devtools/python/python-pycrypto.inc
deleted file mode 100644
index 232cdb7116..0000000000
--- a/meta-python/recipes-devtools/python/python-pycrypto.inc
+++ /dev/null
@@ -1,21 +0,0 @@
-DESCRIPTION = "Cryptographic modules for Python."
-HOMEPAGE = "http://www.pycrypto.org/"
-LICENSE = "PSFv2"
-LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/python-pycrypto:"
-
-DEPENDS += " gmp"
-
-inherit pypi autotools-brokensep
-
-SRC_URI += "file://cross-compiling.patch \
- file://CVE-2013-7459.patch \
- "
-
-SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
-SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
-
-do_compile[noexec] = "1"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch b/meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch
index 9006c5c350..9006c5c350 100644
--- a/meta-python/recipes-devtools/python/python-pycrypto/CVE-2013-7459.patch
+++ b/meta-python/recipes-devtools/python/python3-pycrypto/CVE-2013-7459.patch
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
index 712f3e8dde..712f3e8dde 100644
--- a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch
+++ b/meta-python/recipes-devtools/python/python3-pycrypto/cross-compiling.patch
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
index a20eafec43..78a1ef2ac0 100644
--- a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
@@ -1,7 +1,23 @@
-inherit distutils3
-require python-pycrypto.inc
+DESCRIPTION = "Cryptographic modules for Python."
+HOMEPAGE = "http://www.pycrypto.org/"
+LICENSE = "PSFv2"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
-SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch"
+DEPENDS += " gmp"
+
+export HOST_SYS
+
+inherit pypi autotools-brokensep distutils3
+
+SRC_URI += "file://cross-compiling.patch \
+ file://CVE-2013-7459.patch \
+ file://0001-Replace-time.clock-with-time.process_time.patch \
+ "
+
+SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
+SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
+
+do_compile[noexec] = "1"
# We explicitly call distutils_do_install, since we want it to run, but
# *don't* want the autotools install to run, since this package doesn't
@@ -9,3 +25,5 @@ SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch"
do_install() {
distutils3_do_install
}
+
+BBCLASSEXTEND = "native nativesdk"