aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-08-11 17:38:41 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-11 10:23:54 -0700
commit61638bdba3857825d1306caa67ee58b057d3bbdb (patch)
tree46f322757f0acfe371cc8baa0d4da5413f2a0e86
parent7a512dfc24256f86669cd2774191bb91a282b380 (diff)
downloadmeta-openembedded-contrib-61638bdba3857825d1306caa67ee58b057d3bbdb.tar.gz
jemalloc: add ptest support
Add ptest support. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/jemalloc/files/run-ptest19
-rw-r--r--meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb17
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/jemalloc/files/run-ptest b/meta-oe/recipes-devtools/jemalloc/files/run-ptest
new file mode 100644
index 0000000000..ea9d80cbb6
--- /dev/null
+++ b/meta-oe/recipes-devtools/jemalloc/files/run-ptest
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+saved_dir=$PWD
+for dir in tests/* ; do
+ cd $dir
+ for atest in * ; do
+ if [ \( -x $atest \) -a \( -f $atest \) ] ; then
+ ./$atest > ${atest}.stdout 2> ${atest}.stderr
+ if [ $? = 0 ] ; then
+ echo "PASS: $dir $atest"
+ rm ${atest}.stdout ${atest}.stderr
+ else
+ echo "FAIL: ${dir}/${atest}"
+ fi
+ fi
+ done
+ cd $saved_dir
+done
+
diff --git a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
index b191f729a3..b5d53bb112 100644
--- a/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
+++ b/meta-oe/recipes-devtools/jemalloc/jemalloc_5.2.1.bb
@@ -15,14 +15,29 @@ LIC_FILES_CHKSUM = "file://README;md5=6900e4a158982e4c4715bf16aa54fa10"
SRC_URI = "git://github.com/jemalloc/jemalloc.git \
file://0001-Makefile.in-make-sure-doc-generated-before-install.patch \
+ file://run-ptest \
"
SRCREV = "ea6b3e973b477b8061e0076bb257dbd7f3faa756"
S = "${WORKDIR}/git"
-inherit autotools
+inherit autotools ptest
EXTRA_AUTORECONF += "--exclude=autoheader"
EXTRA_OECONF:append:libc-musl = " --with-jemalloc-prefix=je_"
+
+do_compile_ptest() {
+ oe_runmake tests
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ subdirs="test/unit test/integration test/stress "
+ for tooltest in ${subdirs}
+ do
+ cp -r ${B}/${tooltest} ${D}${PTEST_PATH}/tests
+ done
+ find ${D}${PTEST_PATH}/tests \( -name "*.d" -o -name "*.o" \) -exec rm -f {} \;
+}