aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-04-02 09:39:10 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-01 23:32:54 -0700
commit59438f43e40e2bee05897307cc0bc444b353ab2f (patch)
tree7af560ae177e847effd74314c59dfbfdd632bf84
parent9a156a9f064b54f0d43e08ebd8128c5641eac510 (diff)
downloadmeta-openembedded-contrib-59438f43e40e2bee05897307cc0bc444b353ab2f.tar.gz
python3-polyline: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-polyline/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb15
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-polyline/run-ptest b/meta-python/recipes-devtools/python/python3-polyline/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-polyline/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest
diff --git a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
index 3b3e2071f1..d81ee5445c 100644
--- a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
@@ -6,8 +6,21 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6"
SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb"
SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
RDEPENDS_${PN} += "python3-six"
BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+}