aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Battersby <tonyb@cybernetics.com>2021-08-10 15:44:21 -0400
committerKhem Raj <raj.khem@gmail.com>2021-08-11 10:23:54 -0700
commit48596d4db3b25e7d50c441857dd60f0f0a4c169e (patch)
tree1124d2542a548c06a4fe9b4fe6b43620a549aa37
parent7fd9678e645fb1c167d70f3a7336a7832e9e0693 (diff)
downloadmeta-openembedded-contrib-48596d4db3b25e7d50c441857dd60f0f0a4c169e.tar.gz
tcsh: fix compile error after LDFLAGS change
Adding -f*-prefix-map to LDFLAGS caused the following issue when compiling tcsh on Ubuntu 18.04: gcc: error: unrecognized command line option ‘-fmacro-prefix-map=...’ Fix by using BUILD_LDFLAGS instead of LDFLAGS for gethost. [YOCTO #14481] Signed-off-by: Tony Battersby <tonyb@cybernetics.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb b/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
index ac6c6db813..c4da5cd835 100644
--- a/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
+++ b/meta-oe/recipes-shells/tcsh/tcsh_6.22.04.bb
@@ -20,7 +20,7 @@ EXTRA_OEMAKE += "CC_FOR_GETHOST='${BUILD_CC}'"
inherit autotools
do_compile:prepend() {
- oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' gethost
+ oe_runmake CC_FOR_GETHOST='${BUILD_CC}' CFLAGS='${BUILD_CFLAGS}' LDFLAGS='${BUILD_LDFLAGS}' gethost
}
do_install:append () {