aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-18 12:40:36 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:56:43 -0700
commit3660967a91a58e7820b679cf8fc724cef0a8f52a (patch)
tree20eb663b210c9b484944faf2e9c9be5df34f3aa8
parentf601322416e219cdc95452bed44d25587adab8d1 (diff)
downloadmeta-openembedded-contrib-3660967a91a58e7820b679cf8fc724cef0a8f52a.tar.gz
python3-pandas: Upgrade 1.3.1 -> 1.3.2
Upgrade to release 1.3.2: - Performance regression in DataFrame.isin() and Series.isin() for nullable data types - Regression in updating values of Series using boolean index, created by using DataFrame.pop() - Regression in DataFrame.from_records() with empty records - Fixed regression in DataFrame.shift() where TypeError occurred when shifting DataFrame created by concatenation of slices and fills with values - Regression in DataFrame.agg() when the func argument returned lists and axis=1 - Regression in DataFrame.drop() does nothing if MultiIndex has duplicates and indexer is a tuple or list of tuples - Fixed regression where read_csv() raised a ValueError when parameters names and prefix were both set to None - Fixed regression in comparisons between Timestamp object and datetime64 objects outside the implementation bounds for nanosecond datetime64 - Fixed regression in Styler.highlight_min() and Styler.highlight_max() where pandas.NA was not successfully ignored - Fixed regression in concat() where copy=False was not honored in axis=1 Series concatenation - Regression in Series.nlargest() and Series.nsmallest() with nullable integer or float dtype - Fixed regression in Series.quantile() with Int64Dtype - Bug in read_excel() modifies the dtypes dictionary when reading a file with duplicate columns - 1D slices over extension types turn into N-dimensional slices over ExtensionArrays - Fixed bug in Series.rolling() and DataFrame.rolling() not calculating window bounds correctly for the first row when center=True and window is an offset that covers all the rows - Styler.hide_columns() now hides the index name header row as well as column headers - Styler.set_sticky() has amended CSS to control the column/index names and ensure the correct sticky positions - Bug in de-serializing datetime indexes in PYTHONOPTIMIZED mode Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb b/meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb
index 95fd1fc719..55700b51cf 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.3.2.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
-SRC_URI[sha256sum] = "341935a594db24f3ff07d1b34d1d231786aa9adfa84b76eab10bf42907c8aed3"
+SRC_URI[sha256sum] = "cbcb84d63867af3411fa063af3de64902665bb5b3d40b25b2059e40603594e87"
inherit pypi setuptools3