aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-01-28 19:04:49 -0800
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:44:32 -0800
commit193078e6bb6edbf39d568e5bd7967b757b94ff09 (patch)
treefd1caadce59017137ea8dcface963e7647e5e710
parent0532eaf50b33446ebb2feb7d4d56184a9681b990 (diff)
downloadmeta-openembedded-contrib-193078e6bb6edbf39d568e5bd7967b757b94ff09.tar.gz
python3-h5py: improve reproducibility
Prevent absolute path from ending up in the egg-info SOURCES.txt. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch
new file mode 100644
index 0000000000..da95ee7af5
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup_build.py-avoid-absolute-path.patch
@@ -0,0 +1,30 @@
+From b5d5a7efc7aaa2be830731001ed17c5b71bcefb1 Mon Sep 17 00:00:00 2001
+From: Mingli Yu <mingli.yu@windriver.com>
+Date: Fri, 29 Jan 2021 02:33:06 +0000
+Subject: [PATCH] setup_build.py: avoid absolute path
+
+Prevent absolute path from ending up in the egg-info SOURCES.txt.
+
+Upstream-Status: Submitted [https://github.com/h5py/h5py/pull/1803]
+
+Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
+---
+ setup_build.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup_build.py b/setup_build.py
+index ffd3bef..fb196c0 100644
+--- a/setup_build.py
++++ b/setup_build.py
+@@ -20,7 +20,7 @@ import api_gen
+
+
+ def localpath(*args):
+- return op.abspath(op.join(op.dirname(__file__), *args))
++ return op.join(*args)
+
+
+ MODULES = ['defs','_errors','_objects','_proxy', 'h5fd', 'h5z',
+--
+2.29.2
+
diff --git a/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
index 3904abbb48..b812b323fa 100644
--- a/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-h5py_2.10.0.bb
@@ -9,6 +9,7 @@ SRC_URI[sha256sum] = "84412798925dc870ffd7107f045d7659e60f5d46d1c70c700375248bf6
SRC_URI_append = " \
file://0001-cross-compiling-support.patch \
+ file://0001-setup_build.py-avoid-absolute-path.patch \
"
inherit pypi setuptools3