aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-17 07:26:15 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-17 07:26:15 -0800
commit6dd2a1db71dfa79391bbe956f4d2b5cd15f30a84 (patch)
tree260e546b6a18ec1c08657520a038d5e4e6ffda94
parent0f1e1395066ac43926d0abdf99d9ed76aac2494e (diff)
downloadmeta-openembedded-contrib-6dd2a1db71dfa79391bbe956f4d2b5cd15f30a84.tar.gz
python3-prettytable: fix ptests
A recent upgrade no requires python3-pytest-lazy-fixtures (with the s) instead of python3-pytest-lazy-fixture (without the s). Also, copy the entire tests/ folder to PTEST_DIR Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb b/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
index ba75057f59..5aecde69b8 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_3.9.0.bb
@@ -12,7 +12,6 @@ do_install:append() {
done
}
-BBCLASSEXTEND = "native nativesdk"
inherit pypi ptest python_hatchling
SRC_URI += " \
@@ -34,11 +33,14 @@ RDEPENDS:${PN} += " \
RDEPENDS:${PN}-ptest += " \
python3-pytest \
- python3-pytest-lazy-fixture \
+ python3-pytest-lazy-fixtures \
python3-sqlite3 \
python3-unittest-automake-output \
"
do_install_ptest() {
- cp -f ${S}/tests/test_prettytable.py ${D}${PTEST_PATH}/
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
}
+
+BBCLASSEXTEND = "native nativesdk"