aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2020-09-08 00:41:23 -0700
committerKhem Raj <raj.khem@gmail.com>2020-09-08 11:53:53 -0700
commitc75ffccd840449ba7de745d6f8eae811adb29ff4 (patch)
treed16b69cf5835e36df2b0bf477cadce25e0a5d994
parent648f9a5a6651ad93dda1492017e788c8c4303255 (diff)
downloadmeta-openembedded-contrib-c75ffccd840449ba7de745d6f8eae811adb29ff4.tar.gz
opencv: improve reproducibility
Remove the build host info to improve reproducibility, otherwise there comes below detailed build host info when run below command on target. # python3 /usr/share/opencv4/samples/python/opencv_version.py --build [snip] Extra modules: Location (extra): /buildarea1/master-wr/build/User/customized_next/build/tmp/work/corei7-64-wrs-linux/opencv/4.3.0-r0/contrib/modules [snip] Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.4.0.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.4.0.bb b/meta-oe/recipes-support/opencv/opencv_4.4.0.bb
index 372e15cd00..c83186de07 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.4.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.4.0.bb
@@ -199,6 +199,13 @@ RDEPENDS_python3-opencv = "python3-core python3-numpy"
RDEPENDS_${PN}-apps = "bash"
+do_compile_prepend() {
+ # remove the build host info to improve reproducibility
+ if [ -f ${WORKDIR}/build/modules/core/version_string.inc ]; then
+ sed -i "s#${WORKDIR}#/workdir#g" ${WORKDIR}/build/modules/core/version_string.inc
+ fi
+}
+
do_install_append() {
# Move Python files into correct library folder (for multilib build)
if [ "$libdir" != "/usr/lib" -a -d ${D}/usr/lib ]; then