aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-03-30 13:56:45 +0800
committerKhem Raj <raj.khem@gmail.com>2020-09-16 09:16:41 -0700
commitbccd3277e4b809f7a5fe517c16f5d45e753ce0e4 (patch)
tree5e74b4602d5348122577b052f009496d56c0fff2
parent5b8df78562884b01417b88278591741f6e01bdfc (diff)
downloadmeta-openembedded-contrib-bccd3277e4b809f7a5fe517c16f5d45e753ce0e4.tar.gz
python3-test-generator: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-test-generator/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb16
2 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-test-generator/run-ptest b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest
new file mode 100644
index 0000000000..5cec711696
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-test-generator/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest
diff --git a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
index 14943a4bd5..a83ee5efc2 100644
--- a/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
@@ -5,10 +5,24 @@ parsers that prevent any potentially malicious operation."
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00"
+SRC_URI += " \
+ file://run-ptest \
+"
+
SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1"
SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-mock \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
DEPENDS += "python3-nose-native"