aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-02 14:28:05 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-05 13:04:22 -0700
commitbcb25c13d044f87fa864931097e194a93b9bf978 (patch)
tree383d989fbccd597321ac300de724af5c4ae3e51c
parent03431fe0a422e6ab1ba9f92a63313c96ca2eb2ca (diff)
downloadmeta-openembedded-contrib-bcb25c13d044f87fa864931097e194a93b9bf978.tar.gz
python3-absl: Upgrade 0.9.0 -> 0.10.0
Use PyPI and upgrade to release 0.10.0: Added: - (testing) _TempDir and _TempFile now implement __fspath__ to satisfy os.PathLike - (logging) --logger_levels: allows specifying the log levels of loggers. - (flags) FLAGS.validate_all_flags: a new method that validates all flags and raises an exception if one fails. - (flags) FLAGS.get_flags_for_module: Allows fetching the flags a module defines. - (testing) parameterized.TestCase: Supports async test definitions. - (testing,app) Added --pdb flag: When true, uncaught exceptions will be handled by pdb.post_mortem. This is an alias for --pdb_post_mortem. Changed: - (testing) Failed tests output a copy/pastable test id to make it easier to copy the failing test to the command line. - (testing) @parameterized.parameters now treats a single abc.Mapping as a single test case, consistent with named_parameters. Previously the abc.Mapping is treated as if only its keys are passed as a list of test cases. If you were relying on the old inconsistent behavior, explicitly convert the abc.Mapping to a list. - (flags) DEFINE_enum_class and DEFINE_mutlti_enum_class accept a case_sensitive argument. When False (the default), strings are mapped to enum member names without case sensitivity, and member names are serialized in lowercase form. Flag definitions for enums whose members include duplicates when case is ignored must now explicitly pass case_sensitive=True. Fixed: - (flags) Defining an alias no longer marks the aliased flag as always present on the command line. - (flags) Aliasing a multi flag no longer causes the default value to be appended to. - (flags) Alias default values now matched the aliased default value. - (flags) Alias present counter now correctly reflects command line usage. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-absl_0.10.0.bb (renamed from meta-python/recipes-devtools/python/python3-absl_0.9.0.bb)8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-absl_0.9.0.bb b/meta-python/recipes-devtools/python/python3-absl_0.10.0.bb
index a8f47ba4c1..5be00ccb47 100644
--- a/meta-python/recipes-devtools/python/python3-absl_0.9.0.bb
+++ b/meta-python/recipes-devtools/python/python3-absl_0.10.0.bb
@@ -4,11 +4,11 @@ SECTION = "devel/python"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRC_URI = "git://github.com/abseil/abseil-py.git"
-SRCREV ?= "06edd9c20592cec39178b94240b5e86f32e19768"
+SRC_URI[md5sum] = "9cb38ddf7a2f000e2c92e5d9dfa36ffa"
+SRC_URI[sha256sum] = "b20f504a7871a580be5268a18fbad48af4203df5d33dbc9272426cb806245a45"
-inherit setuptools3
+PYPI_PACKAGE = "absl-py"
-S = "${WORKDIR}/git"
+inherit pypi setuptools3
BBCLASSEXTEND = "native"