aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-09-16 17:23:19 -0700
committerKhem Raj <raj.khem@gmail.com>2020-09-16 17:24:44 -0700
commitad7e4b2fd0096759f10c79cda9ef1d46a30eaa72 (patch)
tree471cea8a8c577e3cd8a7a54d3909fb47b0ec53fc
parentfd96948662fe961d4882376070612bb0357cd303 (diff)
downloadmeta-openembedded-contrib-ad7e4b2fd0096759f10c79cda9ef1d46a30eaa72.tar.gz
st: Use update alternatives
These files are also provided by ncurses so learn to co-habit Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/suckless/st_0.8.4.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/suckless/st_0.8.4.bb b/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
index 906179501b..1f0f2f7f2c 100644
--- a/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
+++ b/meta-oe/recipes-graphics/suckless/st_0.8.4.bb
@@ -23,3 +23,13 @@ do_install() {
FILES_${PN} += " \
${datadir}/terminfo \
"
+
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "50"
+
+ALTERNATIVE_${PN} = "st st-256color"
+
+ALTERNATIVE_LINK_NAME[st] = "${datadir}/terminfo/s/st"
+
+ALTERNATIVE_LINK_NAME[st-256color] = "${datadir}/terminfo/s/st-256color"