aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2020-09-14 12:20:05 -0400
committerKhem Raj <raj.khem@gmail.com>2020-09-15 09:28:34 -0700
commitab05d6522f51757667a24b15966b76fa4e75a244 (patch)
tree20a54c2cf2785934910c36cf725916ff9b70de5a
parent87229e8aaebb479c086bcdf4199bd5a3d27ca5e2 (diff)
downloadmeta-openembedded-contrib-ab05d6522f51757667a24b15966b76fa4e75a244.tar.gz
python3-django: add recipe for 3.1.1
meta-python only contains a recipe for django 2.2.x, so add a recipe file for the newest branch. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-django_3.1.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-django_3.1.1.bb b/meta-python/recipes-devtools/python/python3-django_3.1.1.bb
new file mode 100644
index 0000000000..ed6513d0c2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-django_3.1.1.bb
@@ -0,0 +1,14 @@
+require python-django.inc
+inherit setuptools3
+
+SRC_URI[md5sum] = "d5e894fb3c46064e84e9dc68a08a46d0"
+SRC_URI[sha256sum] = "59c8125ca873ed3bdae9c12b146fbbd6ed8d0f743e4cf5f5817af50c51f1fc2f"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-sqlparse \
+"
+
+# Set DEFAULT_PREFERENCE so that the LTS version of django is built by
+# default. To build the 3.x branch,
+# PREFERRED_VERSION_python3-django = "3.1.1" can be added to local.conf
+DEFAULT_PREFERENCE = "-1"