aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-09-09 10:45:37 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-10 01:24:33 -0700
commit5d28b4ec75fc5836c8d7acefd5fbeb2d70367e33 (patch)
tree85ee4576b5be744c5e32de965a323666f689d86f
parenta2409e6cd12d584d32fbdc062976e9db05d18017 (diff)
downloadmeta-openembedded-contrib-5d28b4ec75fc5836c8d7acefd5fbeb2d70367e33.tar.gz
libcec: workaround wrong choice of PYTHON_PKG_DIR when building on Debian
As described in https://github.com/Pulse-Eight/libcec/issues/530 the cmake code looks at the host to make decisions about the target, and we can't even override this with a flag. Signed-off-by: Yann Dirson <yann@blade-group.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch31
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_6.0.2.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch b/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch
new file mode 100644
index 0000000000..7c29e15e20
--- /dev/null
+++ b/meta-oe/recipes-extended/libcec/libcec/0001-Remove-buggy-test-confusing-host-and-target.patch
@@ -0,0 +1,31 @@
+From 8ce50bf569ec2d931735180079bbe507730626c8 Mon Sep 17 00:00:00 2001
+From: Yann Dirson <yann@blade-group.com>
+Date: Mon, 7 Sep 2020 18:17:21 +0200
+Subject: [PATCH] Remove buggy test confusing host and target
+
+---
+ src/libcec/cmake/CheckPlatformSupport.cmake | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/src/libcec/cmake/CheckPlatformSupport.cmake b/src/libcec/cmake/CheckPlatformSupport.cmake
+index 1d99bd8..31dac4f 100644
+--- a/src/libcec/cmake/CheckPlatformSupport.cmake
++++ b/src/libcec/cmake/CheckPlatformSupport.cmake
+@@ -266,14 +266,6 @@ else()
+ DESTINATION python/cec)
+ endif()
+ else()
+- if(EXISTS "/etc/os-release")
+- file(READ "/etc/os-release" OS_RELEASE)
+- string(REGEX MATCH "ID(_LIKE)?=debian" IS_DEBIAN ${OS_RELEASE})
+- if (IS_DEBIAN)
+- SET(PYTHON_PKG_DIR "dist-packages")
+- endif()
+- endif()
+-
+ if (NOT PYTHON_PKG_DIR)
+ SET(PYTHON_PKG_DIR "site-packages")
+ endif()
+--
+2.28.0
+
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
index 894ee52f96..c4aeb8c555 100644
--- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
@@ -13,6 +13,7 @@ SRCREV = "29d82c80bcc62be2878a9ac080de7eb286c4beb9"
SRC_URI = "git://github.com/Pulse-Eight/libcec.git;branch=release \
file://0001-CheckPlatformSupport.cmake-Do-not-hardcode-lib-path.patch \
file://0001-Enhance-reproducibility.patch \
+ file://0001-Remove-buggy-test-confusing-host-and-target.patch \
"
S = "${WORKDIR}/git"