aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYann Dirson <yann@blade-group.com>2020-09-09 10:45:40 +0200
committerKhem Raj <raj.khem@gmail.com>2020-09-10 01:24:33 -0700
commit58ba034db7379ff1714054ece5074a4c6ef61505 (patch)
treeae7fa5efec9ab9c858ae07d00d54926465768e6b
parente59b461d19d59b45467ec9933f9c1bb4b962ec4e (diff)
downloadmeta-openembedded-contrib-58ba034db7379ff1714054ece5074a4c6ef61505.tar.gz
libcec: split the python example into a separate package
It does not provide more functionality than the C-based examples, so is of little value on a target except for checking the python module is working. Signed-off-by: Yann Dirson <yann@blade-group.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/libcec/libcec_6.0.2.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
index f55801c390..48be1fdac5 100644
--- a/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
+++ b/meta-oe/recipes-extended/libcec/libcec_6.0.2.bb
@@ -24,10 +24,11 @@ inherit cmake pkgconfig
PLATFORM_CMAKE_FLAGS ?= "-DHAVE_LINUX_API=1 -DHAVE_RPI_API=0"
EXTRA_OECMAKE += "${PLATFORM_CMAKE_FLAGS}"
-# Put client examples into a separate package
-PACKAGE_BEFORE_PN += "${PN}-examples"
+# Put client examples into separate packages
+PACKAGE_BEFORE_PN += "${PN}-examples-python ${PN}-examples"
+FILES_${PN}-examples-python = "${bindir}/py*"
FILES_${PN}-examples = "${bindir}"
-RDEPENDS_${PN}-examples = "python3-${BPN} python3-core"
+RDEPENDS_${PN}-examples-python = "python3-${BPN} python3-core"
# Create the wrapper for python3
PACKAGES += "python3-${BPN}"