aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-03 16:35:18 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-10 01:24:34 -0700
commit1c7b46f706f0fdfce6aef02cf241d1ea5fbade21 (patch)
treeb3418884fb5a4d3b1e3114d08b0ead9f5a17b67b
parente43a9898fc536d1d3bc726180d5c2afd15db0b19 (diff)
downloadmeta-openembedded-contrib-1c7b46f706f0fdfce6aef02cf241d1ea5fbade21.tar.gz
python3-isort: Upgrade 5.4.2 -> 5.5.0
- Fixed: isort: off comment doesn't work, if it's the top comment in the file. - Fixed: reverse_relative setting doesn't have any effect when combined with force_sort_within_sections. - Fixed: --skip can error in the case of projects that contain recursive symlinks. - Fixed: ensure_newline_before_comments doesn't work if comment is at top of section and sections don't have lines between them. - Fixed: comments in imports with ";" can keep isort from recognizing import line. - Fixed: As imports removed when combine_star is set. - Fixed: --float-to-top has no effect if no import is already at the top. - Fixed: isort never settles on module docstring + add import. - Fixed: Error raised when repo contains circular symlinks. - Fixed: noqa comment is moved from star import to constant import. - Fixed: Incorrect placement of import additions. - Fixed: isort5 throws error when stdin used on Windows with deprecated args. - Added support for specifying config file when using git hook. - Added support for coloring diff output. - New multi-line grid mode without parentheses. - Extensive profile testing. - Proprety based testing applied to code snippets. - Create automated integration test that includes full code base of largest OpenSource isort users. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_5.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-isort_5.4.2.bb)4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-isort_5.4.2.bb b/meta-python/recipes-devtools/python/python3-isort_5.5.0.bb
index 6b1cee40d1..ee13d76e56 100644
--- a/meta-python/recipes-devtools/python/python3-isort_5.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-isort_5.5.0.bb
@@ -4,8 +4,8 @@ LICENSE = "MIT"
SECTION = "devel/python"
LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=6;endline=6;md5=8227180126797a0148f94f483f3e1489"
-SRC_URI[md5sum] = "59592b6e14beba48149d651e900e3815"
-SRC_URI[sha256sum] = "d488ba1c5a2db721669cc180180d5acf84ebdc5af7827f7aaeaa75f73cf0e2b8"
+SRC_URI[md5sum] = "9560df531409e67ac8796e98ffcb6124"
+SRC_URI[sha256sum] = "0906e0e7092e060c05de709ad172e1ec1b26aa27fdd4e8093f257890cd881d18"
inherit pypi setuptools3