aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-11 23:42:58 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commitd9f027866664d7e70d6491b3131e6245e3daff90 (patch)
tree886d31bd54c3f8cb7eb821f1a8021c297c96e4ee
parentf751dcf81a18fe817b40e755a2ba3f54a74d1e02 (diff)
downloadmeta-openembedded-contrib-d9f027866664d7e70d6491b3131e6245e3daff90.tar.gz
htop: Fix build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/htop/files/htop-gcc10.patch31
-rw-r--r--meta-oe/recipes-support/htop/htop_2.2.0.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/htop/files/htop-gcc10.patch b/meta-oe/recipes-support/htop/files/htop-gcc10.patch
new file mode 100644
index 0000000000..5be06277d7
--- /dev/null
+++ b/meta-oe/recipes-support/htop/files/htop-gcc10.patch
@@ -0,0 +1,31 @@
+Fix build with -fno-common
+
+Upstream-Staus: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/CRT.h
++++ b/CRT.h
+@@ -140,7 +140,7 @@ extern const char **CRT_treeStr;
+
+ extern int CRT_delay;
+
+-int* CRT_colors;
++extern int* CRT_colors;
+
+ extern int CRT_colorSchemes[LAST_COLORSCHEME][LAST_COLORELEMENT];
+
+@@ -150,13 +150,13 @@ extern int CRT_scrollHAmount;
+
+ extern int CRT_scrollWheelVAmount;
+
+-char* CRT_termType;
++extern char* CRT_termType;
+
+ // TODO move color scheme to Settings, perhaps?
+
+ extern int CRT_colorScheme;
+
+-void *backtraceArray[128];
++extern void *backtraceArray[128];
+
+ #if HAVE_SETUID_ENABLED
+
diff --git a/meta-oe/recipes-support/htop/htop_2.2.0.bb b/meta-oe/recipes-support/htop/htop_2.2.0.bb
index 64eb0c571f..c608077dee 100644
--- a/meta-oe/recipes-support/htop/htop_2.2.0.bb
+++ b/meta-oe/recipes-support/htop/htop_2.2.0.bb
@@ -9,6 +9,7 @@ DEPENDS = "ncurses"
SRC_URI = "http://hisham.hm/htop/releases/${PV}/${BP}.tar.gz \
file://0001-Use-pkg-config.patch \
file://0001-Ask-for-python3-specifically.patch \
+ file://htop-gcc10.patch \
"
SRC_URI[md5sum] = "0d816b6beed31edc75babcfbf863ffa8"
SRC_URI[sha256sum] = "d9d6826f10ce3887950d709b53ee1d8c1849a70fa38e91d5896ad8cbc6ba3c57"