aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-12 13:09:08 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commitbd499150d29a7c62d706f85ca5d879b2db772192 (patch)
tree9400c350832f68ece32c0779b3bc7d0408469e5d
parent4928a2b6e95ac07ee82aa0acc0cf9c186ef03fd5 (diff)
downloadmeta-openembedded-contrib-bd499150d29a7c62d706f85ca5d879b2db772192.tar.gz
drbd-utils: Uphgrade to 9.13.1
Fix build with gcc10 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch32
-rw-r--r--meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb (renamed from meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb)10
2 files changed, 38 insertions, 4 deletions
diff --git a/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch b/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch
new file mode 100644
index 0000000000..6702f3bde4
--- /dev/null
+++ b/meta-networking/recipes-support/drbd/drbd-utils/0001-v84-Make-setup_options-definitions-as-extern.patch
@@ -0,0 +1,32 @@
+From d095caf6f8f77fe056fb90ccd5d89c207a7f346d Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 12:59:38 -0700
+Subject: [PATCH] v84: Make setup_options definitions as extern
+
+This is already defined in drbdadm_main.c, therefore make this
+declaration to be extern for other modules
+
+Fixes compatibility with gcc-10 which uses -fno-common by default
+
+Upstream-Status: Submitted [https://github.com/LINBIT/drbd-utils/pull/7]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ user/v84/drbdadm.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/user/v84/drbdadm.h b/user/v84/drbdadm.h
+index ed63d78c..8469f1c4 100644
+--- a/user/v84/drbdadm.h
++++ b/user/v84/drbdadm.h
+@@ -251,7 +251,7 @@ struct setup_option {
+ bool explicit;
+ char *option;
+ };
+-struct setup_option *setup_options;
++extern struct setup_option *setup_options;
+
+ extern void add_setup_option(bool explicit, char *option);
+
+--
+2.28.0
+
diff --git a/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb b/meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb
index 5dabdd51d0..5b0979f961 100644
--- a/meta-networking/recipes-support/drbd/drbd-utils_9.12.0.bb
+++ b/meta-networking/recipes-support/drbd/drbd-utils_9.13.1.bb
@@ -8,13 +8,15 @@ SECTION = "admin"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
-SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
+SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils;branch=${PV} \
git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
+ file://0001-v84-Make-setup_options-definitions-as-extern.patch \
${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-drbd-utils-support-usrmerge.patch','',d)} \
"
-# v9.12.0
-SRCREV_drbd-utils = "91629a4cce49ca0d4f917fe0bffa25cfe8db3052"
-SRCREV_drbd-headers = "233006b4d26cf319638be0ef6d16ec7dee287b66"
+SRCREV_drbd-utils = "b24b0f7e42d500d3538d7eeffa017ec78d08f918"
+SRCREV_drbd-headers = "c757cf357edef67751b8f45a6ea894d287180087"
+
+SRCREV_FORMAT = "drbd-utils_drbd-headers"
S = "${WORKDIR}/git"