aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-12 10:02:56 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commitb66dc11366b77e201cf699da98617e214385a810 (patch)
tree96b1d7cee6423084b412d9ec2586ccd4a45963e3
parent7c505534496d77769779f0c184c4bf96d72038ea (diff)
downloadmeta-openembedded-contrib-b66dc11366b77e201cf699da98617e214385a810.tar.gz
netperf: Fix build with -fno-common
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/netperf/files/0001-nettest_omni-Remove-duplicate-variable-definitions.patch37
-rw-r--r--meta-networking/recipes-support/netperf/netperf_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/netperf/files/0001-nettest_omni-Remove-duplicate-variable-definitions.patch b/meta-networking/recipes-support/netperf/files/0001-nettest_omni-Remove-duplicate-variable-definitions.patch
new file mode 100644
index 0000000000..08376417ba
--- /dev/null
+++ b/meta-networking/recipes-support/netperf/files/0001-nettest_omni-Remove-duplicate-variable-definitions.patch
@@ -0,0 +1,37 @@
+From 6dd5b2b1f3ae3479647e2ef66e390d031066defe Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 12 Aug 2020 09:57:23 -0700
+Subject: [PATCH] nettest_omni: Remove duplicate variable definitions
+
+These defines are already defined in nettest_bsd.c and exported by
+nettest_bsd.h this should fix build with -fno-common
+
+Upstream-Status: Submitted [https://github.com/HewlettPackard/netperf/pull/46]
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/nettest_omni.c | 8 --------
+ 1 file changed, 8 deletions(-)
+
+diff --git a/src/nettest_omni.c b/src/nettest_omni.c
+index 852eeb1..862088a 100644
+--- a/src/nettest_omni.c
++++ b/src/nettest_omni.c
+@@ -458,14 +458,6 @@ static int client_port_max = 65535;
+
+ /* different options for the sockets */
+
+-int
+- loc_nodelay, /* don't/do use NODELAY locally */
+- rem_nodelay, /* don't/do use NODELAY remotely */
+- loc_sndavoid, /* avoid send copies locally */
+- loc_rcvavoid, /* avoid recv copies locally */
+- rem_sndavoid, /* avoid send copies remotely */
+- rem_rcvavoid; /* avoid recv_copies remotely */
+-
+ extern int
+ loc_tcpcork,
+ rem_tcpcork,
+--
+2.28.0
+
diff --git a/meta-networking/recipes-support/netperf/netperf_git.bb b/meta-networking/recipes-support/netperf/netperf_git.bb
index d48f3aeabd..a084fb4c15 100644
--- a/meta-networking/recipes-support/netperf/netperf_git.bb
+++ b/meta-networking/recipes-support/netperf/netperf_git.bb
@@ -13,6 +13,7 @@ SRC_URI = "git://github.com/HewlettPackard/netperf.git \
file://vfork.patch \
file://init \
file://0001-netlib.c-Move-including-sched.h-out-og-function.patch \
+ file://0001-nettest_omni-Remove-duplicate-variable-definitions.patch \
"
SRCREV = "f482bab49fcedee46fc5b755da127f608325cd13"