aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-11 14:44:29 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:07 -0700
commita5e99dd2693a36bc2750d8d59fc3f786758caebf (patch)
tree978086b2b501f04b3e935e50489af91cfaf213be
parent6bd5cd84055e745f759ede4ea3085c71398fb924 (diff)
downloadmeta-openembedded-contrib-a5e99dd2693a36bc2750d8d59fc3f786758caebf.tar.gz
python3-flask-login: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python-flask-login.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-login_0.4.1.bb16
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-login.inc b/meta-python/recipes-devtools/python/python-flask-login.inc
deleted file mode 100644
index 59eb64f778..0000000000
--- a/meta-python/recipes-devtools/python/python-flask-login.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "User session management for Flask"
-DESCRIPTION = "Flask-Login provides user session management for Flask. \
-It handles the common tasks of logging in, logging out, and remembering \
-your users’ sessions over extended periods of time."
-HOMEPAGE = " https://github.com/maxcountryman/flask-login"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8aa87a1cd9fa41d969ad32cfdac2c596"
-
-SRC_URI[md5sum] = "25b34c74bd509792f291c16e184225df"
-SRC_URI[sha256sum] = "c815c1ac7b3e35e2081685e389a665f2c74d7e077cb93cecabaea352da4752ec"
-
-PYPI_PACKAGE = "Flask-Login"
-
-RDEPENDS_${PN}_class-target = "${PYTHON_PN}-flask"
diff --git a/meta-python/recipes-devtools/python/python3-flask-login_0.4.1.bb b/meta-python/recipes-devtools/python/python3-flask-login_0.4.1.bb
index 2d23fe1674..ba335579b4 100644
--- a/meta-python/recipes-devtools/python/python3-flask-login_0.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-flask-login_0.4.1.bb
@@ -1,2 +1,16 @@
+SUMMARY = "User session management for Flask"
+DESCRIPTION = "Flask-Login provides user session management for Flask. \
+It handles the common tasks of logging in, logging out, and remembering \
+your users’ sessions over extended periods of time."
+HOMEPAGE = " https://github.com/maxcountryman/flask-login"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8aa87a1cd9fa41d969ad32cfdac2c596"
+
+SRC_URI[md5sum] = "25b34c74bd509792f291c16e184225df"
+SRC_URI[sha256sum] = "c815c1ac7b3e35e2081685e389a665f2c74d7e077cb93cecabaea352da4752ec"
+
+PYPI_PACKAGE = "Flask-Login"
+
inherit pypi setuptools3
-require python-flask-login.inc
+
+RDEPENDS_${PN}_class-target = "${PYTHON_PN}-flask"