aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2020-09-21 16:09:27 -0700
committerTim Orling <ticotimo@gmail.com>2020-09-21 16:51:25 -0700
commit26234a6ac0d9598a185568222f527e4995f707e6 (patch)
treec6b8585af5d17ede26d4ac79b1176dcb8edbd389
parente7bf8b6cb2eac640e1f71ef08eb9398e7df661d4 (diff)
downloadmeta-openembedded-contrib-26234a6ac0d9598a185568222f527e4995f707e6.tar.gz
python3-markupsafe: bbappend for ptest
The main recipe has moved to oe-core, but with ptest disabled. Here we simply conditionally inherit ptest to enable it in meta-python. Remove the original recipe and the python3-markupsafe/ directory. Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend2
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb27
3 files changed, 2 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest b/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest
deleted file mode 100644
index 5cec711696..0000000000
--- a/meta-python/recipes-devtools/python/python3-markupsafe/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-pytest
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
new file mode 100644
index 0000000000..91814e6cde
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-markupsafe_1.%.bbappend
@@ -0,0 +1,2 @@
+# Main recipe was moved to oe-core, but with ptest disabled
+inherit ${@bb.utils.filter('DISTRO_FEATURES', 'ptest', d)}
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb b/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
deleted file mode 100644
index 7de57cbd63..0000000000
--- a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
-HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
-
-SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b"
-SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b"
-
-PYPI_PACKAGE = "MarkupSafe"
-inherit pypi ptest setuptools3
-
-RDEPENDS_${PN} += "${PYTHON_PN}-stringold"
-
-BBCLASSEXTEND = "native nativesdk"
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
-}