aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-08-12 16:02:04 -0700
committerKhem Raj <raj.khem@gmail.com>2020-08-13 22:32:08 -0700
commit178a52005111c971b46f8c7d6ffca2ffa5092e8e (patch)
treeff44e3bb5249a25e1dc2938e1e2a90e6b04cf5c4
parentc3f9e92fb2137ae24e70c3f0d957397748727c13 (diff)
downloadmeta-openembedded-contrib-178a52005111c971b46f8c7d6ffca2ffa5092e8e.tar.gz
python3-pandas: Add workaround to fix build with clang
This is a bug introduced by cython [1] the workaround suppressed the additional warnings seen with clang [2] [1] https://github.com/cython/cython/issues/3474 [2] https://github.com/pandas-dev/pandas/issues/33239 Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.1.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.1.0.bb b/meta-python/recipes-devtools/python/python3-pandas_1.1.0.bb
index f100677caa..7d65287cb0 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.1.0.bb
@@ -15,6 +15,8 @@ DEPENDS += " \
${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
"
+CFLAGS_append_toolchain-clang = " -Wno-error=deprecated-declarations"
+
RDEPENDS_${PN} += " \
${PYTHON_PN}-json \
${PYTHON_PN}-numpy \