aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Blanchard <anton@ozlabs.org>2021-08-17 21:15:33 +1000
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:58:56 -0700
commitc207d6b5ab2ab360aec8e902e868f2845c500aa5 (patch)
treed7c6e77a3b4a3ada06c7cdf6f134e6064c8aa62e
parentb2e90f4e2f9539960ad4004bf0ff62510d9b1740 (diff)
downloadmeta-openembedded-contrib-c207d6b5ab2ab360aec8e902e868f2845c500aa5.tar.gz
boost-url: Use GNUInstallDirs instead of hard wiring install directories
On a multilib setup cmake files should go into lib64. Signed-off-by: Anton Blanchard <anton@ozlabs.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch57
-rw-r--r--meta-oe/recipes-devtools/boost-url/boost-url_git.bb4
2 files changed, 60 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch b/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
new file mode 100644
index 0000000000..4c996656c0
--- /dev/null
+++ b/meta-oe/recipes-devtools/boost-url/boost-url/0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch
@@ -0,0 +1,57 @@
+From 329e27c8ad30e76ab50c7949cc95ba8eb0efabd2 Mon Sep 17 00:00:00 2001
+From: Anton Blanchard <anton@ozlabs.org>
+Date: Tue, 17 Aug 2021 09:53:41 +1000
+Subject: [PATCH] Use GNUInstallDirs instead of hard wiring install directories
+
+On a multilib setup cmake files should go into lib64.
+
+Upstream-Status: Submitted [https://github.com/CPPAlliance/url/pull/38]
+---
+ CMakeLists.txt | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 5b53f31..ebb7346 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -109,20 +109,22 @@ else()
+ endif()
+
+ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST_TREE)
++ include(GNUInstallDirs)
++
+ set_target_properties(boost_url PROPERTIES EXPORT_NAME url)
+ install(TARGETS boost_url EXPORT boost_url_targets)
+
+ install(EXPORT boost_url_targets
+ FILE boost_url-targets.cmake
+ NAMESPACE Boost::
+- DESTINATION lib/cmake/boost_url
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
+ )
+
+ include(CMakePackageConfigHelpers)
+
+ configure_package_config_file(cmake/config.cmake.in
+ ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake
+- INSTALL_DESTINATION lib/cmake/boost_url
++ INSTALL_DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
+ )
+
+ write_basic_package_version_file(${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake
+@@ -132,10 +134,10 @@ if(CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR AND NOT BOOST_URL_IN_BOOST
+ install(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config.cmake
+ ${CMAKE_CURRENT_BINARY_DIR}/boost_url-config-version.cmake
+- DESTINATION lib/cmake/boost_url
++ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/boost_url
+ )
+
+- install(DIRECTORY include/ DESTINATION include)
++ install(DIRECTORY include/ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
+ endif()
+
+ if(BOOST_URL_BUILD_TESTS)
+--
+2.31.1
+
diff --git a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
index 107a4a8331..cb3664fe30 100644
--- a/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
+++ b/meta-oe/recipes-devtools/boost-url/boost-url_git.bb
@@ -4,7 +4,9 @@ SECTION = "libs"
LICENSE = "BSL-1.0"
LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop"
+SRC_URI = "git://github.com/CPPAlliance/url.git;branch=develop \
+ file://0001-Use-GNUInstallDirs-instead-of-hard-wiring-install-di.patch \
+ "
SRCREV = "2c867fbe284ae532f1329b87a86ad3f8cd382867"