aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-18 15:44:38 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commite86355f2a27ab155d0db241a99f099468868a685 (patch)
tree1207ccb65da2d8b5f80d06a986e32b5a565c69a0
parent070b92a3f64e2eee9388d64dc193aaa9d8c115d8 (diff)
downloadmeta-openembedded-contrib-e86355f2a27ab155d0db241a99f099468868a685.tar.gz
lv-drivers: Lint recipe
Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb25
1 files changed, 9 insertions, 16 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
index a7478d4d5b..750312844a 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -1,21 +1,18 @@
# SPDX-FileCopyrightText: Huawei Inc.
+#
# SPDX-License-Identifier: MIT
-# TODO: Pin upstream release (current v7.11.0-80-g419a757)
-src_org = "lvgl"
-SRC_URI = "gitsm://github.com/${src_org}/lv_drivers;destsuffix=${S};protocol=https;nobranch=1"
-SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
-
HOMEPAGE = "https://docs.lvgl.io/latest/en/html/porting/index.html"
SUMMARY = "LVGL's Display and Touch pad drivers"
DESCRIPTION = "Collection of drivers: SDL, framebuffer, wayland and more..."
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
+
+# TODO: Pin upstream release (current v7.11.0-80-g419a757)
+SRC_URI = "git://github.com/lvgl/lv_drivers;destsuffix=${S};protocol=https;nobranch=1"
+SRCREV = "419a757c23aaa67c676fe3a2196d64808fcf2254"
-DEPENDS += "libxkbcommon"
-DEPENDS += "lvgl"
-DEPENDS += "wayland"
+DEPENDS = "libxkbcommon lvgl wayland"
REQUIRED_DISTRO_FEATURES = "wayland"
@@ -29,7 +26,6 @@ EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
-
do_configure:append() {
[ -r "${S}/lv_drv_conf.h" ] \
|| sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
@@ -37,9 +33,6 @@ do_configure:append() {
< "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h"
}
-
-FILES:${PN}-dev = "\
+FILES:${PN}-dev += "\
${includedir}/lvgl/lv_drivers/ \
"
-
-FILES:${PN}-staticdev = "${libdir}/"