aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Klein <matthias@extraklein.de>2021-10-27 14:41:46 +0200
committerKhem Raj <raj.khem@gmail.com>2021-10-27 07:11:22 -0700
commitaa40b5c785b99283756197bbe054378a4cc41263 (patch)
tree14aa426c7c43aa8f845a810319ddd41e8f2291dc
parent6440f73b120de2064c45d357b8fab83be29c4c1b (diff)
downloadmeta-openembedded-contrib-aa40b5c785b99283756197bbe054378a4cc41263.tar.gz
gpsd: Install also the generated parts of the Python library
The Python library cannot be copied from the source code directory, otherwise generated files like gps.py and packet.py are missing. This is noticed when starting ubxtool which otherwise crashes: Traceback (most recent call last): File "/usr/bin/ubxtool", line 48, in <module> import gps.ubx File "/usr/lib/python3.10/site-packages/gps/ubx.py", line 244, in <module> class ubx(object): File "/usr/lib/python3.10/site-packages/gps/ubx.py", line 255, in ubx verbosity = gps.VERB_NONE AttributeError: module 'gps' has no attribute 'VERB_NONE' Signed-off-by: Matthias Klein <matthias@extraklein.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
index 4740e0c987..8763c68ed7 100644
--- a/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
+++ b/meta-oe/recipes-navigation/gpsd/gpsd_3.23.1.bb
@@ -72,7 +72,7 @@ do_install:append() {
# Support for python
install -d ${D}${PYTHON_SITEPACKAGES_DIR}/gps
- install -m 755 ${S}/gps/*.py ${D}${PYTHON_SITEPACKAGES_DIR}/gps
+ install -m 755 ${D}${libdir}/gps/*.py ${D}${PYTHON_SITEPACKAGES_DIR}/gps
}
PACKAGES =+ "libgps libgpsd python3-pygps gpsd-udev gpsd-conf gpsd-gpsctl gps-utils"