aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-30 11:02:44 -0700
committerKhem Raj <raj.khem@gmail.com>2021-11-01 05:45:17 -0700
commita61be25234b879d1f523fb6208054432390a67d9 (patch)
treea27b8ea9ff11864e0b294a0e8d502d57205cb222
parente53d796e1f4767e7d7f7aab3e77200bdc27856df (diff)
downloadmeta-openembedded-contrib-a61be25234b879d1f523fb6208054432390a67d9.tar.gz
mtr: Fix build with ncurses 6.3+
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-support/mtr/mtr/0001-Fix-a-lot-of-Werror-format-security-errors-in-printw.patch68
-rw-r--r--meta-networking/recipes-support/mtr/mtr_0.94.bb4
2 files changed, 71 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/mtr/mtr/0001-Fix-a-lot-of-Werror-format-security-errors-in-printw.patch b/meta-networking/recipes-support/mtr/mtr/0001-Fix-a-lot-of-Werror-format-security-errors-in-printw.patch
new file mode 100644
index 0000000000..5a8ee49d53
--- /dev/null
+++ b/meta-networking/recipes-support/mtr/mtr/0001-Fix-a-lot-of-Werror-format-security-errors-in-printw.patch
@@ -0,0 +1,68 @@
+From 628b4b3a16c5e3416aac3eea041ff03375fb495b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 30 Oct 2021 11:00:59 -0700
+Subject: [PATCH] Fix a lot of -Werror=format-security errors in
+ printw/mvprintw
+
+In all these places a non-constant is used as a format string which
+compiler complains about. Fix by using "%s" as format.
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ ui/curses.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/ui/curses.c b/ui/curses.c
+index 34bf30d..c24cf28 100644
+--- a/ui/curses.c
++++ b/ui/curses.c
+@@ -432,7 +432,7 @@ static void mtr_curses_hosts(
+ attron(A_BOLD);
+ #ifdef HAVE_IPINFO
+ if (is_printii(ctl))
+- printw(fmt_ipinfo(ctl, addr));
++ printw("%s", fmt_ipinfo(ctl, addr));
+ #endif
+ if (name != NULL) {
+ if (ctl->show_ips)
+@@ -485,7 +485,7 @@ static void mtr_curses_hosts(
+ printw("\n ");
+ #ifdef HAVE_IPINFO
+ if (is_printii(ctl))
+- printw(fmt_ipinfo(ctl, addrs));
++ printw("%s", fmt_ipinfo(ctl, addrs));
+ #endif
+ if (name != NULL) {
+ if (ctl->show_ips)
+@@ -650,7 +650,7 @@ static void mtr_curses_graph(
+
+ #ifdef HAVE_IPINFO
+ if (is_printii(ctl))
+- printw(fmt_ipinfo(ctl, addr));
++ printw("%s", fmt_ipinfo(ctl, addr));
+ #endif
+ name = dns_lookup(ctl, addr);
+ printw("%s", name ? name : strlongip(ctl, addr));
+@@ -700,7 +700,7 @@ void mtr_curses_redraw(
+
+ mvprintw(1, 0, "%s (%s) -> %s", ctl->LocalHostname, net_localaddr(), ctl->Hostname);
+ t = time(NULL);
+- mvprintw(1, maxx - 25, iso_time(&t));
++ mvprintw(1, maxx - 25, "%s", iso_time(&t));
+ printw("\n");
+
+ printw("Keys: ");
+@@ -760,7 +760,7 @@ void mtr_curses_redraw(
+ startstat = padding - 2;
+
+ snprintf(msg, sizeof(msg), " Last %3d pings", max_cols);
+- mvprintw(rowstat - 1, startstat, msg);
++ mvprintw(rowstat - 1, startstat, "%s", msg);
+
+ attroff(A_BOLD);
+ move(rowstat, 0);
+--
+2.33.1
+
diff --git a/meta-networking/recipes-support/mtr/mtr_0.94.bb b/meta-networking/recipes-support/mtr/mtr_0.94.bb
index c046499a2f..c066be1428 100644
--- a/meta-networking/recipes-support/mtr/mtr_0.94.bb
+++ b/meta-networking/recipes-support/mtr/mtr_0.94.bb
@@ -9,7 +9,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://ui/mtr.c;beginline=5;endline=16;md5=00a894a39d53726a27386534d1c4e468"
SRCREV = "2c73cbf4094e4eed343ed11ae5bab2580f3122d1"
-SRC_URI = "git://github.com/traviscross/mtr"
+SRC_URI = "git://github.com/traviscross/mtr \
+ file://0001-Fix-a-lot-of-Werror-format-security-errors-in-printw.patch \
+ "
S = "${WORKDIR}/git"