aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaciej Borzecki <maciej.borzecki@open-rnd.pl>2015-07-13 14:44:11 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:03:26 +0200
commit4eb06c68fbbc9ba9dd9925ad807a1cc087d58974 (patch)
treea05fbd3f6462f59ab68c2d262720a48a3f75b9fa
parent16fc3475bc0fb9fb82dcb3ba2483623ccb7c41a1 (diff)
downloadmeta-openembedded-contrib-4eb06c68fbbc9ba9dd9925ad807a1cc087d58974.tar.gz
python-sparts: add recipe
Adding recipe for python-sparts, a library for rapid service prototyping. Change-Id: I9de406dc40267e008f5a67f0d4d91ed47a707262 Signed-off-by: Maciej Borzecki <maciej.borzecki@open-rnd.pl> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-sparts_0.7.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-sparts_0.7.2.bb b/meta-python/recipes-devtools/python/python-sparts_0.7.2.bb
new file mode 100644
index 0000000000..e9a9e64716
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-sparts_0.7.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Library for rapid service prototyping with minimal boilerplate"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0c1554636a564da3baf037ac652fc831"
+SRCNAME = "sparts"
+
+SRC_URI = "git://github.com/facebook/sparts.git"
+SRCREV = "128cf9c2f82b00cb2d8648033970870c73641f02"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools
+
+RDEPENDS_${PN} = "\
+ python-subprocess \
+ python-six \
+ python-argparse \
+ python-re \
+ python-shell \
+ python-threading \
+ python-logging \
+ python-unixadmin \
+ python-distutils \
+ python-daemonize \
+ python-futures \
+"