aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2015-04-01 11:24:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-04-13 12:55:50 +0200
commit2900fef5c56627351003a4995c58968295ca085d (patch)
treeae2bb57cc8ebe48981fdef876ceccc8911e58bc3
parent90b13eded76f7f7fa1a6715e67c32504e7788e96 (diff)
downloadmeta-openembedded-contrib-2900fef5c56627351003a4995c58968295ca085d.tar.gz
fbida: update to 2.10
This release fixes QA Issue [file-rdeps] Changes: - fix HAVE_LIBUNGIF => HAVE_LIBGIF - add "curl" and "webp" to PACKAGECONFIG Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.10.bb (renamed from meta-oe/recipes-graphics/fbida/fbida_git.bb)21
1 files changed, 14 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
index 41c14b88af..c7195fc98f 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_git.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
@@ -8,20 +8,21 @@ SECTION = "utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
-DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl"
+DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif"
-SRC_URI = "git://git.kraxel.org/fbida"
-SRCREV = "6aa5563cb3c8864ad15cf83eb6fca3b773da1099"
-PV = "2.09+git${SRCPV}"
-S = "${WORKDIR}/git"
+SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz"
+SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018"
+SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
EXTRA_OEMAKE = "STRIP="
-PACKAGECONFIG ??= "gif png"
+PACKAGECONFIG ??= "gif png curl"
+PACKAGECONFIG[curl] = ",,curl"
PACKAGECONFIG[gif] = ",,giflib"
PACKAGECONFIG[png] = ",,libpng"
PACKAGECONFIG[tiff] = ",,tiff"
PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
+PACKAGECONFIG[webp] = ",,libwebp"
do_compile() {
sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
@@ -29,8 +30,11 @@ do_compile() {
# Be sure to respect preferences (force to "no")
# Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
+ if [ -z "${@base_contains('PACKAGECONFIG', 'curl', 'curl', '', d)}" ]; then
+ sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
+ fi
if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
- sed -i -e '/^HAVE_LIBUNGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
+ sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
fi
if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
@@ -41,6 +45,9 @@ do_compile() {
if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
fi
+ if [ -z "${@base_contains('PACKAGECONFIG', 'webp', 'webp', '', d)}" ]; then
+ sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
+ fi
oe_runmake
}