aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-02-25 11:06:27 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-25 13:00:14 -0800
commitf7112f5b6fc23ec8a88d2abd4f3e061460c3ef40 (patch)
tree5cc5ca329d7f82b6c05e992679c5ab65f2fdec45
parentcfabc986f40051e95ee48755c26f7057430df942 (diff)
downloadmeta-openembedded-contrib-f7112f5b6fc23ec8a88d2abd4f3e061460c3ef40.tar.gz
layer.conf: change layer priority to match oe-core
Layer priority is the ultimate decider of what recipe is used: if layer A has recipe foo_1 and layer B has recipe foo_2, if layer A's priority is higher than B then foo_1 will be used, even though the version in B is higher, and even if PREFERRED_VERSION_foo is set to 2. This complicates recipes moving between layers, for example when a newer version of a recipe (say, python3-wheel) is taken from a layer with a higher priority (say, meta-python) and moved to a layer with a lower priority (say, oe-core) then it has to be removed before it is added: there is no way to have it in both layers and work correctly. Higher priorities are useful in distribution layers where you may want to override specific recipes without any other fuss. However as all of the layers in meta-oe simply add more recipes in defined areas, there's no need to have a higher layer priority. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-filesystems/conf/layer.conf2
-rw-r--r--meta-gnome/conf/layer.conf2
-rw-r--r--meta-initramfs/conf/layer.conf2
-rw-r--r--meta-multimedia/conf/layer.conf2
-rw-r--r--meta-oe/conf/layer.conf2
-rw-r--r--meta-perl/conf/layer.conf2
-rw-r--r--meta-python/conf/layer.conf2
-rw-r--r--meta-webserver/conf/layer.conf2
-rw-r--r--meta-xfce/conf/layer.conf2
9 files changed, 9 insertions, 9 deletions
diff --git a/meta-filesystems/conf/layer.conf b/meta-filesystems/conf/layer.conf
index b5f59d9bac..75a27d6654 100644
--- a/meta-filesystems/conf/layer.conf
+++ b/meta-filesystems/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "filesystems-layer"
BBFILE_PATTERN_filesystems-layer = "^${LAYERDIR}/"
-BBFILE_PRIORITY_filesystems-layer = "6"
+BBFILE_PRIORITY_filesystems-layer = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
diff --git a/meta-gnome/conf/layer.conf b/meta-gnome/conf/layer.conf
index 3f6b4f7b76..2fb3485155 100644
--- a/meta-gnome/conf/layer.conf
+++ b/meta-gnome/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "gnome-layer"
BBFILE_PATTERN_gnome-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_gnome-layer = "7"
+BBFILE_PRIORITY_gnome-layer = "5"
# auto-pack gnome help files
IMAGE_LINGUAS_COMPLEMENTARY:append = " ${@bb.utils.contains('DISTRO_FEATURES','helpfiles','*-help-%s','',d)}"
diff --git a/meta-initramfs/conf/layer.conf b/meta-initramfs/conf/layer.conf
index 33e61d333f..c63383faf7 100644
--- a/meta-initramfs/conf/layer.conf
+++ b/meta-initramfs/conf/layer.conf
@@ -13,7 +13,7 @@ BBFILE_PATTERN_meta-initramfs := "^${LAYERDIR}/"
# choosing carefully how this layer interacts with all of the
# other layers.
-BBFILE_PRIORITY_meta-initramfs = "8"
+BBFILE_PRIORITY_meta-initramfs = "5"
LAYERDEPENDS_meta-initramfs = "core"
LAYERSERIES_COMPAT_meta-initramfs = "kirkstone"
diff --git a/meta-multimedia/conf/layer.conf b/meta-multimedia/conf/layer.conf
index 1fe9c80330..b5120bb539 100644
--- a/meta-multimedia/conf/layer.conf
+++ b/meta-multimedia/conf/layer.conf
@@ -23,7 +23,7 @@ LICENSE_PATH += "${LAYERDIR}/licenses"
# choosing carefully how this layer interacts with all of the
# other layers.
-BBFILE_PRIORITY_multimedia-layer = "6"
+BBFILE_PRIORITY_multimedia-layer = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index 93f3dc5807..88715d5e82 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -21,7 +21,7 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
# choosing carefully how this layer interacts with all of the
# other layers.
-BBFILE_PRIORITY_openembedded-layer = "6"
+BBFILE_PRIORITY_openembedded-layer = "5"
# only activates content when identified layers are present,
# to ensure yocto compatibility check pass
diff --git a/meta-perl/conf/layer.conf b/meta-perl/conf/layer.conf
index 4f075e9a92..3cb9571d41 100644
--- a/meta-perl/conf/layer.conf
+++ b/meta-perl/conf/layer.conf
@@ -7,7 +7,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
BBFILE_COLLECTIONS += "perl-layer"
BBFILE_PATTERN_perl-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_perl-layer = "6"
+BBFILE_PRIORITY_perl-layer = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
diff --git a/meta-python/conf/layer.conf b/meta-python/conf/layer.conf
index 98f734152f..e444498ff0 100644
--- a/meta-python/conf/layer.conf
+++ b/meta-python/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes*/*/*.bb ${LAYERDIR}/recipes*/*/*.bbappend"
BBFILE_COLLECTIONS += "meta-python"
BBFILE_PATTERN_meta-python := "^${LAYERDIR}/"
-BBFILE_PRIORITY_meta-python = "7"
+BBFILE_PRIORITY_meta-python = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
diff --git a/meta-webserver/conf/layer.conf b/meta-webserver/conf/layer.conf
index 312c39b3b3..5ae5e796ae 100644
--- a/meta-webserver/conf/layer.conf
+++ b/meta-webserver/conf/layer.conf
@@ -9,7 +9,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "webserver"
BBFILE_PATTERN_webserver := "^${LAYERDIR}/"
-BBFILE_PRIORITY_webserver = "6"
+BBFILE_PRIORITY_webserver = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
diff --git a/meta-xfce/conf/layer.conf b/meta-xfce/conf/layer.conf
index be58708679..28dfc5b340 100644
--- a/meta-xfce/conf/layer.conf
+++ b/meta-xfce/conf/layer.conf
@@ -6,7 +6,7 @@ BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"
BBFILE_COLLECTIONS += "xfce-layer"
BBFILE_PATTERN_xfce-layer := "^${LAYERDIR}/"
-BBFILE_PRIORITY_xfce-layer = "7"
+BBFILE_PRIORITY_xfce-layer = "5"
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers