aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 19:50:42 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commitf3455a942b089cf792e863a279dc3f28920259b7 (patch)
tree23d0e065a2ff5306ff90a65bde9243208071b305
parente37adcb1361ff4b68d4761ac5675759d01e61c3d (diff)
downloadmeta-openembedded-contrib-f3455a942b089cf792e863a279dc3f28920259b7.tar.gz
python3-xlrd: fix wheel build
Recipe does not inherit pypi nor would PN resolve to a useful name for the wheel. Set PIP_INSTALL_PACKAGE appropriately. Recipe builds wheel in ${S}/dist so set PIP_INSTALL_DIST_PATH appropriately. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
index bd6853e747..da0dc26715 100644
--- a/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-xlrd_2.0.1.bb
@@ -17,6 +17,8 @@ SRCREV = "b8d573e11ec149da695d695c81a156232b89a949"
S = "${WORKDIR}/git"
inherit ptest setuptools3
+PIP_INSTALL_PACKAGE = "xlrd"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
RDEPENDS:${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"