aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-27 12:07:14 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:48 -0800
commitca15f8baeb183d2667880fa9e572e0ea557099b5 (patch)
treee70c18484057832f6f3cdf7a659e427a6c4024b1
parentb20c58079815206e56b1bdf554ffda9e0aecf5d6 (diff)
downloadmeta-openembedded-contrib-ca15f8baeb183d2667880fa9e572e0ea557099b5.tar.gz
python3-systemd: patch to use setuptools
setup.py bdist_wheel does not work with ditutils (which is deprecated anyway). Add a patch to switch to setuptools to allow wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch30
-rw-r--r--meta-python/recipes-devtools/python/python3-systemd_234.bb5
2 files changed, 34 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
new file mode 100644
index 0000000000..b3180f29f2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-systemd/0002-setup.py-switch-from-distutils-to-setuptools.patch
@@ -0,0 +1,30 @@
+From a681a79472df85cdc8c052bc61fb8b9e7b9a6495 Mon Sep 17 00:00:00 2001
+From: Tim Orling <tim.orling@konsulko.com>
+Date: Sun, 27 Feb 2022 11:50:36 -0800
+Subject: [PATCH] setup.py: switch from distutils to setuptools
+
+In Python 3.10, distutils is deprecated and slated for removal in Python
+3.12. It also prevents 'setup.py bdist_wheel' from building a wheel.
+
+Upstream-Status: Submitted
+[https://github.com/systemd/python-systemd/pull/103]
+
+Signed-off-by: Tim Orling <tim.orling@konsulko.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 099819b..fe9c03a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,5 +1,5 @@
+ import sys, os
+-from distutils.core import setup, Extension
++from setuptools import setup, Extension
+ from subprocess import Popen, PIPE, check_output
+
+ def call(*cmd):
+--
+2.30.2
+
diff --git a/meta-python/recipes-devtools/python/python3-systemd_234.bb b/meta-python/recipes-devtools/python/python3-systemd_234.bb
index cbc9f44bc7..1aecb375bf 100644
--- a/meta-python/recipes-devtools/python/python3-systemd_234.bb
+++ b/meta-python/recipes-devtools/python/python3-systemd_234.bb
@@ -15,6 +15,9 @@ SRC_URI[sha256sum] = "fd0e44bf70eadae45aadc292cb0a7eb5b0b6372cd1b391228047d33895
# allow for common patches for python- and python3-systemd
FILESEXTRAPATHS:prepend := "${THISDIR}/python-systemd:"
-SRC_URI += "file://endian.patch"
+SRC_URI += " \
+ file://endian.patch \
+ file://0002-setup.py-switch-from-distutils-to-setuptools.patch \
+"
SRC_URI:append:libc-musl = " file://0001-Provide-implementation-of-strndupa-for-musl.patch"