aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-28 08:02:03 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-28 08:02:03 -0800
commita5a5004f1bbc36569ce4794eaac5bb6d164c6bb6 (patch)
tree9d3eb7a0daa54279bad073ed0df6785ec87cd920
parent195453deffc364871a7c5ed07b13a91d92e95aff (diff)
downloadmeta-openembedded-contrib-a5a5004f1bbc36569ce4794eaac5bb6d164c6bb6.tar.gz
python3-sdnotify: patch to use setuptools
setup.py bdist_wheel does not work with distutils (which is deprecated anyway). Add a patch to switch to setuptools to allow the wheel to be built. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch31
-rw-r--r--meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb3
2 files changed, 33 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch
new file mode 100644
index 0000000000..cf7696aa63
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sdnotify/0001-setup.py-switch-to-setuptools.patch
@@ -0,0 +1,31 @@
+From f662280b26eb1549890e88e8e9085f1937d7962d Mon Sep 17 00:00:00 2001
+From: Tim Orling <tim.orling@konsulko.com>
+Date: Mon, 28 Feb 2022 07:54:03 -0800
+Subject: [PATCH] setup.py: switch to setuptools
+
+In Python 3.10, 'distutils' is deprecated and is slated for removal in
+Python 3.12.
+
+Switch from distutils.core to setuptools. This also allows the 'wheel'
+binary archive format to be built with 'setup.py bdist_wheel'.
+
+Upstream-Status: Submitted [https://github.com/bb4242/sdnotify/pull/7]
+
+Signed-off-by: Tim Orling <tim.orling@konsulko.com>
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 433222c..32b5bd6 100644
+--- a/setup.py
++++ b/setup.py
+@@ -1,4 +1,4 @@
+-from distutils.core import setup
++from setuptools import setup
+
+ VERSION='0.3.2'
+
+--
+2.30.2
+
diff --git a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
index 221a8c8717..dc1961ac30 100644
--- a/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-sdnotify_0.3.2.bb
@@ -12,7 +12,8 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cc572ccc4b18a4b7d13be5d01bc8213e"
-SRC_URI[md5sum] = "749ddca1c70be1697fecc443fb1fdb16"
SRC_URI[sha256sum] = "73977fc746b36cc41184dd43c3fe81323e7b8b06c2bb0826c4f59a20c56bb9f1"
+SRC_URI += "file://0001-setup.py-switch-to-setuptools.patch"
+
inherit setuptools3 pypi