aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-25 20:46:39 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:47 -0800
commit9755a16cf8852b20e38f12ccb79847a175d03ed8 (patch)
treed28c30ff241dedcf6320a4070d31f8593f700499
parentff9202e1753ae6db5d25b7b01722ba99258b4c56 (diff)
downloadmeta-openembedded-contrib-9755a16cf8852b20e38f12ccb79847a175d03ed8.tar.gz
[WIP] python3-blivet: fix wheel build
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
index 85f80b8c05..237f3fe2bb 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.0.bb
@@ -29,6 +29,9 @@ REQUIRED_DISTRO_FEATURES = "systemd"
inherit setuptools3 python3native
+PIP_INSTALL_PACKAGE = "blivet"
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
parted python3-pyparted multipath-tools \
lsof cryptsetup libblockdev \