aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-02-23 15:17:19 +0200
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:30:26 -0800
commit91704ff653938938fad1053bb75093f30e551294 (patch)
treed6a4b528f6f92cc255bcaf4d4dd4fcff163eb617
parent2ffdf3c3408b3dfaa2cd5dd8cd73727c2d94a206 (diff)
downloadmeta-openembedded-contrib-91704ff653938938fad1053bb75093f30e551294.tar.gz
python3-pandas: Upgrade 1.4.0 -> 1.4.1
Upgrade to release 1.4.1: - Regression in Series.mask() with inplace=True and PeriodDtype and an incompatible other coercing to a common dtype instead of raising - Regression in assert_frame_equal() not respecting check_flags=False - Regression in DataFrame.loc() raising ValueError when indexing (getting values) on a MultiIndex with one level - Regression in Series.fillna() with downcast=False incorrectly downcasting object dtype - Regression in api.types.is_bool_dtype() raising an AttributeError when evaluating a categorical Series - Regression in DataFrame.iat() setting values leading to not propagating correctly in subsequent lookups - Regression when setting values with DataFrame.loc() losing Index name if DataFrame was empty before - Regression in join() with overlapping IntervalIndex raising an InvalidIndexError - Regression when setting values with Series.loc() raising with all False indexer and Series on the right hand side - Regression in read_sql() with a DBAPI2 connection that is not an instance of sqlite3.Connection incorrectly requiring SQLAlchemy be installed - Regression in DateOffset when constructing with an integer argument with no keywords (e.g. pd.DateOffset(n)) would behave like datetime.timedelta(days=0) - Fixed segfault in DataFrame.to_json() when dumping tz-aware datetimes in Python 3.10 - Stopped emitting unnecessary FutureWarning in DataFrame.sort_values() with sparse columns - Fixed window aggregations in DataFrame.rolling() and Series.rolling() to skip over unused elements - Fixed builtin highlighters in Styler to be responsive to NA with nullable dtypes - Bug in apply() with axis=1 raising an erroneous ValueError - Reverted performance speedup of DataFrame.corr() for method=pearson to fix precision regression Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.4.1.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.4.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pandas_1.4.1.bb
index 9b395440f9..4877194a5c 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.4.1.bb
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
-SRC_URI[sha256sum] = "cdd76254c7f0a1583bd4e4781fb450d0ebf392e10d3f12e92c95575942e37df5"
+SRC_URI[sha256sum] = "8db93ec98ac7cb5f8ac1420c10f5e3c43533153f253fe7fb6d891cf5aa2b80d2"
inherit pypi setuptools3