aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 10:55:51 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-25 13:00:14 -0800
commit2002f6f243195dc908d9e2957988ee5f2231c863 (patch)
treef825a05819b58547f65d9935dce1d4a653b5fe11
parentf82b518cb64005962dfdd789849dd4356a67d8cf (diff)
downloadmeta-openembedded-contrib-2002f6f243195dc908d9e2957988ee5f2231c863.tar.gz
python3-pyruvate: fix wheel build
Like python3-setuptools-rust-native, the wheel is being built in ${S}/dist rather than ${B}/dist so set PIP_INSTALL_DIST_PATH accordingly. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
index b83302d44c..4429e4c32a 100644
--- a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
@@ -14,6 +14,8 @@ S = "${WORKDIR}/pyruvate-${PV}"
inherit pypi setuptools3_rust
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+
# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64
# not supported on mips/powerpc with 32-bit pointers
# https://doc.rust-lang.org/std/sync/atomic/#portability