aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-24 21:04:17 -0800
committerTim Orling <tim.orling@konsulko.com>2022-02-27 12:57:38 -0800
commit065f1e9b51a68bd9dc1dea5521d1559ba1960950 (patch)
tree050abf5377adc71d918f55e5c390ba142f37fd47
parent24c9a01ac18bc19a2200c0602cd3f2c055a2cd8e (diff)
downloadmeta-openembedded-contrib-065f1e9b51a68bd9dc1dea5521d1559ba1960950.tar.gz
python3-poetry-core: add v1.0.7
A PEP 517 build backend implementation developed for Poetry. This project is intended to be a light weight, fully compliant, self-contained package allowing PEP 517 compatible build frontends to build Poetry managed projects. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-poetry-core_1.0.7.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-poetry-core_1.0.7.bb b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.7.bb
new file mode 100644
index 0000000000..ecec38ca85
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.7.bb
@@ -0,0 +1,58 @@
+SUMMARY = "Poetry PEP 517 Build Backend"
+DESCRIPTION = "Poetry PEP 517 Build Backend"
+HOMEPAGE = "https://github.com/python-poetry/poetry-core"
+BUGTRACKER = "https://github.com/python-poetry/poetry-core"
+CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md"
+
+LICENSE = "Apache-2.0 & BSD-2-Clause & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=104d5c3c653aeededf4076773aa4c236 \
+ file://poetry/core/_vendor/attrs.LICENSE;md5=75bb9823a2778b5a2bd9b793fac93ea2 \
+ file://poetry/core/_vendor/jsonschema/COPYING;md5=6554d3a51d7cb0b611891317f3c69057 \
+ file://poetry/core/_vendor/jsonschema/LICENSE;md5=2ecb81765361195731a6f72a89e449fd \
+ file://poetry/core/_vendor/lark-parser.LICENSE;md5=b37b83a9cf129d92ee65aaa71c01ce72 \
+ file://poetry/core/_vendor/packaging/LICENSE;md5=7a6e56c9d54ecd731ab31c52de7942f0 \
+ file://poetry/core/_vendor/packaging/LICENSE.APACHE;md5=29256199be2a609aac596980ffc11996 \
+ file://poetry/core/_vendor/packaging/LICENSE.BSD;md5=f405810d173a1618433827928768bcd2 \
+ file://poetry/core/_vendor/pyparsing.LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a \
+ file://poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=1211a1ac6eac40020d0f99c39b4e4270 \
+ file://poetry/core/_vendor/six.LICENSE;md5=6a574656da93d9ef05431b45907e35b6 \
+ file://poetry/core/_vendor/tomlkit/LICENSE;md5=be329e5ef9c9fe86738c9afe6ef3c11c \
+ "
+
+SRC_URI[sha256sum] = "98c11c755a16ef6c5673c22ca94a3802a7df4746a0853a70b6fae8b9f5cac206"
+
+inherit pip_install_wheel python3native python3-dir pypi setuptools3-base
+
+DEPENDS += "python3"
+
+RDEPENDS:${PN}:append:class-target = "\
+ python3-compression \
+ python3-core \
+ python3-crypt \
+ python3-io \
+ python3-json \
+ python3-logging \
+ python3-netclient \
+ python3-pathlib2 \
+ python3-pprint \
+ python3-shell \
+"
+
+RDEPENDS:${PN} += "\
+ python3-pip \
+ python3-six \
+"
+
+do_configure () {
+ mkdir -p ${B}/dist
+ cat > ${B}/build-it.py << EOF
+from poetry.core.masonry import api
+api.build_wheel('${B}/dist')
+EOF
+}
+
+do_compile () {
+ ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} ${B}/build-it.py
+}
+
+BBCLASSEXTEND = "native nativesdk"