aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2020-04-24 11:16:04 +0200
committerKhem Raj <raj.khem@gmail.com>2020-04-25 08:32:42 -0700
commitb3013a0bc9e4c9c0ee5a1cb6fce6a458fbcf1478 (patch)
tree91ad8f8c00ee0d175196876bc6ce3a4a11914473
parentcfdd71dd09339f79d27df5c13d503e9826f638c5 (diff)
downloadmeta-openembedded-contrib-b3013a0bc9e4c9c0ee5a1cb6fce6a458fbcf1478.tar.gz
daemontools: use u-a for /usr/bin/svc and /usr/bin/svok
* busybox provides the same, causing busybox postinst to fail when both packages are installed in the same image: update-alternatives: Error: not linking rootfs/usr/bin/svc to /usr/bin/busybox.nosuid since rootfs/usr/bin/svc exists and is not a link update-alternatives: Error: not linking rootfs/usr/bin/svok to /usr/bin/busybox.nosuid since rootfs/usr/bin/svok exists and is not a link Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/daemontools/daemontools_0.76.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/daemontools/daemontools_0.76.bb b/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
index b99116da70..f0c5f7d7de 100644
--- a/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
+++ b/meta-oe/recipes-support/daemontools/daemontools_0.76.bb
@@ -38,3 +38,7 @@ do_install() {
do_install_append_class-target() {
install -m755 ${S}/command/* ${D}/${bindir}
}
+
+inherit update-alternatives
+ALTERNATIVE_PRIORITY = "100"
+ALTERNATIVE_${PN} = "svc svok"