aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-18 09:37:25 -0700
committerKhem Raj <raj.khem@gmail.com>2020-04-19 11:55:06 -0700
commit0651858d83c58937eeddd6f872a78d7a034822dd (patch)
tree980ce53608dd76b7adcf0f65755c7764bb4a35fb
parent9b61f412d36b390f8d71ad1fb5875f5f6e32fd8a (diff)
downloadmeta-openembedded-contrib-0651858d83c58937eeddd6f872a78d7a034822dd.tar.gz
sysdig: Do not depend on luaJIT for riscv
LuaJIT is not porteed to riscv yet Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sysdig/sysdig_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sysdig/sysdig_git.bb b/meta-oe/recipes-extended/sysdig/sysdig_git.bb
index 8074b2e0e1..04a022af4f 100644
--- a/meta-oe/recipes-extended/sysdig/sysdig_git.bb
+++ b/meta-oe/recipes-extended/sysdig/sysdig_git.bb
@@ -12,6 +12,8 @@ inherit cmake pkgconfig
JIT ?= "jit"
JIT_mipsarchn32 = ""
JIT_mipsarchn64 = ""
+JIT_riscv64 = ""
+JIT_riscv32 = ""
DEPENDS += "lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
RDEPENDS_${PN} = "bash"
@@ -48,3 +50,5 @@ FILES_${PN} += " \
# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
COMPATIBLE_HOST_libc-musl = "null"
COMPATIBLE_HOST_mips = "null"
+COMPATIBLE_HOST_riscv64 = "null"
+COMPATIBLE_HOST_riscv32 = "null"