aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2024-02-16 11:29:35 -0800
committerTim Orling <tim.orling@konsulko.com>2024-02-16 12:30:46 -0800
commit169b7ba5dd117b09906920c329c176635625df9a (patch)
tree62cb9cb610a9f14a07fb901d0b1edb24790149db
parentb039f2a5a504c797efed80e2194c01eb99750321 (diff)
downloadmeta-openembedded-contrib-169b7ba5dd117b09906920c329c176635625df9a.tar.gz
python3-scrypt: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt/run-ptest b/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
index c386932683..ce0d4de9c4 100644
--- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.20.bb
@@ -14,11 +14,12 @@ SRC_URI += " \
"
RDEPENDS:${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
+ python3-pytest \
+ python3-unittest-automake-output \
"
RDEPENDS:${PN} += " \
- ${PYTHON_PN}-ctypes \
+ python3-ctypes \
"
do_install_ptest() {