aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoy Li <rongqing.li@windriver.com>2015-07-07 13:14:40 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-30 21:31:02 +0200
commit7ca0d80cb6bba7b4a43e18df0d48bc1d66841a1c (patch)
tree51856ab0a682350a2bc7fdd80d2a3f2641723077
parent77c9fb809448d94bddc9a92166110518053f5879 (diff)
downloadmeta-openembedded-contrib-7ca0d80cb6bba7b4a43e18df0d48bc1d66841a1c.tar.gz
hostapd: consider sysroot when search header files
Signed-off-by: Roy Li <rongqing.li@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch40
-rw-r--r--meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb1
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch
new file mode 100644
index 0000000000..d1134b9aa7
--- /dev/null
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd-2.2/add-sysroot-to-gcc.patch
@@ -0,0 +1,40 @@
+Upstream-Status: Pending
+
+We should make sure that sysroot is used by gcc instead of assuming
+hardcoded locations for include paths
+
+Signed-off-by: Roy Li <rongqing.li@windriver.com>
+---
+ src/drivers/drivers.mak | 2 +-
+ src/drivers/drivers.mk | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/drivers/drivers.mak b/src/drivers/drivers.mak
+index 7e175f4..950701f 100644
+--- a/src/drivers/drivers.mak
++++ b/src/drivers/drivers.mak
+@@ -35,7 +35,7 @@ NEED_RFKILL=y
+ ifdef CONFIG_LIBNL32
+ DRV_LIBS += -lnl-3
+ DRV_LIBS += -lnl-genl-3
+- DRV_CFLAGS += -DCONFIG_LIBNL20 -I/usr/include/libnl3
++ DRV_CFLAGS += -DCONFIG_LIBNL20 -I=/usr/include/libnl3
+ else
+ ifdef CONFIG_LIBNL_TINY
+ DRV_LIBS += -lnl-tiny
+diff --git a/src/drivers/drivers.mk b/src/drivers/drivers.mk
+index db8561a..c93e88d 100644
+--- a/src/drivers/drivers.mk
++++ b/src/drivers/drivers.mk
+@@ -30,7 +30,7 @@ NEED_RFKILL=y
+ ifdef CONFIG_LIBNL32
+ DRV_LIBS += -lnl-3
+ DRV_LIBS += -lnl-genl-3
+- DRV_CFLAGS += -DCONFIG_LIBNL20 -I/usr/include/libnl3
++ DRV_CFLAGS += -DCONFIG_LIBNL20 -I=/usr/include/libnl3
+ else
+ ifdef CONFIG_LIBNL_TINY
+ DRV_LIBS += -lnl-tiny
+--
+2.1.2
+
diff --git a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
index b75f2b9a7e..02b78f1862 100644
--- a/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
+++ b/meta-oe/recipes-connectivity/hostapd/hostapd_2.2.bb
@@ -18,6 +18,7 @@ SRC_URI = " \
file://defconfig \
file://init \
file://hostapd.service \
+ file://add-sysroot-to-gcc.patch;patchdir=.. \
"
S = "${WORKDIR}/hostapd-${PV}/hostapd"