aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-07-07 16:09:13 +0300
committerKhem Raj <raj.khem@gmail.com>2021-07-08 09:17:50 -0700
commit4c35a3276e1ec66c6d0ae2e2b4f034a435eb0b66 (patch)
tree8eb113e474eddea160d8a611f42d578871b2fb02
parente75141814c4e246b573a106ac4b0c2a824ca16ce (diff)
downloadmeta-openembedded-contrib-4c35a3276e1ec66c6d0ae2e2b4f034a435eb0b66.tar.gz
python3-cmd2: Upgrade 2.1.1 -> 2.1.2
Upgrade to release 2.1.2: - Added the following accessor methods for cmd2-specific attributes to the argparse.Action class: * get_choices_callable() * set_choices_provider() * set_completer() * get_descriptive_header() * set_descriptive_header() * get_nargs_range() * set_nargs_range() * get_suppress_tab_hint() * set_suppress_tab_hint() - Now that set_choices_provider() and set_completer() have been added as methods to the argparse.Action class, the standalone functions of the same name will be removed in version 2.2.0. To update to the new convention, do the following: * Change set_choices_provider(action, provider) to action.set_choices_provider(provider) * Change set_completer(action, completer) to action.set_completer(completer) License-Update: Update years Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb)5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb b/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb
index e663b9c815..38f050a044 100644
--- a/meta-python/recipes-devtools/python/python3-cmd2_2.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cmd2_2.1.2.bb
@@ -1,11 +1,11 @@
SUMMARY = "Extra features for standard library's cmd module"
HOMEPAGE = "https://github.com/python-cmd2/cmd2"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=9791cd24ca7d1807388ccd55cd066def"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-SRC_URI[sha256sum] = "a45f6a50b6081c5767b0e410da3f9cebdf6d8fb2aff80fab07d633c6eaaa6d70"
+SRC_URI[sha256sum] = "25dbb2e9847aaa686a8a21e84e3d101db8b79f5cb992e044fc54210ab8c0ad41"
inherit pypi setuptools3
@@ -16,6 +16,7 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-wcwidth \
${PYTHON_PN}-compression \
${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-json \
"
BBCLASSEXTEND = "native nativesdk"