aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-02-02 12:21:34 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2023-02-15 18:24:31 +0100
commit4f6ce61d7f48fbea64dff69e84f3e1eb6d2f52a2 (patch)
tree90e1d1965f95c1ceb4f840d51c69ba95970510db
parentaaeb992070b1afaba4b4480e0dc817753152c696 (diff)
downloadmeta-openembedded-contrib-4f6ce61d7f48fbea64dff69e84f3e1eb6d2f52a2.tar.gz
opencv: add PACKAGECONFIG for carotene
* just as temporary work around for carotene triggering ICE with gcc-13: opencv/4.6.0-r0/git/3rdparty/carotene/src/flip.cpp:98:1: internal compiler error: in cselib_subst_to_values, at cselib.cc:2148 98 | } | ^ 0x1afbcbb internal_error(char const*, ...) ???:0 0x6e40e4 fancy_abort(char const*, int, char const*) ???:0 0xa12da1 cselib_subst_to_values_from_insn(rtx_def*, machine_mode, rtx_insn*) ???:0 0x1a4f9b1 deps_analyze_insn(deps_desc*, rtx_insn*) ???:0 0x1a501da sched_analyze(deps_desc*, rtx_insn*, rtx_insn*) ???:0 0x1a532f6 schedule_ebb(rtx_insn*, rtx_insn*, bool) ???:0 0x1a537e3 schedule_ebbs() ???:0 Please submit a full bug report, with preprocessed source (by using -freport-bug). Please include the complete backtrace with any bug report. See <https://gcc.gnu.org/bugs/> for instructions. * it was enabled by default for arm and aarch64 unless CV_DISABLE_OPTIMIZATION was set * there is a fix for ICE itself in: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=108463 but after backporting it it causes the build to hang (similarly as with -fsched2-use-superblocks removed), so it needs to be investigated more Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/opencv/opencv_4.6.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
index fcbafd78a9..8a445c423d 100644
--- a/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
+++ b/meta-oe/recipes-support/opencv/opencv_4.6.0.bb
@@ -122,6 +122,7 @@ PACKAGECONFIG:remove:libc-musl:riscv32 = "tbb"
PACKAGECONFIG[gapi] = "-DWITH_ADE=ON -Dade_DIR=${STAGING_LIBDIR},-DWITH_ADE=OFF,ade"
PACKAGECONFIG[amdblas] = "-DWITH_OPENCLAMDBLAS=ON,-DWITH_OPENCLAMDBLAS=OFF,libclamdblas,"
PACKAGECONFIG[amdfft] = "-DWITH_OPENCLAMDFFT=ON,-DWITH_OPENCLAMDFFT=OFF,libclamdfft,"
+PACKAGECONFIG[carotene] = "-DWITH_CAROTENE=ON,-DWITH_CAROTENE=OFF,,"
PACKAGECONFIG[dnn] = "-DBUILD_opencv_dnn=ON -DPROTOBUF_UPDATE_FILES=ON -DBUILD_PROTOBUF=OFF,-DBUILD_opencv_dnn=OFF,protobuf protobuf-native,"
PACKAGECONFIG[eigen] = "-DWITH_EIGEN=ON,-DWITH_EIGEN=OFF,libeigen gflags glog,"
PACKAGECONFIG[freetype] = "-DBUILD_opencv_freetype=ON,-DBUILD_opencv_freetype=OFF,freetype,"