aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbhargav_das@mentor.com <bhargav_das@mentor.com>2023-02-13 00:28:50 +0530
committerKhem Raj <raj.khem@gmail.com>2023-02-12 21:48:33 -0800
commit34f2312f3defd8feac52a0f74fb950ece8436112 (patch)
tree3e06f21668f172a312fefb18ac57d23a2f5487c7
parent32824df3b5dcc9bc5a2ead79e622cd7f17ee7fc4 (diff)
downloadmeta-openembedded-contrib-34f2312f3defd8feac52a0f74fb950ece8436112.tar.gz
python3-daemon_2.3.2.bb: add python-daemon recipe for python3
python-daemon was part of meta-python2 this has now been updated to python3 and v2.3.2 Signed-off-by: Bhargav Das <bhargav_das@mentor.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb b/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
new file mode 100644
index 0000000000..49b094fce0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-daemon_2.3.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Library to implement a well-behaved Unix daemon process"
+HOMEPAGE = "https://pagure.io/python-daemon/"
+SECTION = "devel/python"
+
+DEPENDS += "${PYTHON_PN}-docutils-native"
+RDEPENDS:${PN} = "${PYTHON_PN}-docutils \
+ ${PYTHON_PN}-lockfile (>= 0.10) \
+ ${PYTHON_PN}-resource \
+"
+
+LICENSE = "Apache-2.0 & GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://README;md5=a3a94c615dc969a70525f1eebbacf235"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "b7397fe73d516dc14921500a1245b41c"
+SRC_URI[sha256sum] = "3deeb808e72b6b89f98611889e11cc33754f5b2c1517ecfa1aaf25f402051fb5"
+
+PYPI_PACKAGE = "python-daemon"