aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Geelen <t.f.g.geelen@gmail.com>2024-02-04 11:39:29 +0000
committerKhem Raj <raj.khem@gmail.com>2024-02-04 07:14:59 -0800
commit3c6b9945629df7322c80b84e74369f925ac90237 (patch)
tree1513a4d1d2ba9dda8dd4345b201fdf968b2afdd4
parenta8714fd4a6d1e186a1e3cd2c79b3f8a2818f92e5 (diff)
downloadmeta-openembedded-contrib-3c6b9945629df7322c80b84e74369f925ac90237.tar.gz
python3-pychromecast: add missing RDEPENDS, and add initial recipe for dependency.
python3-pychromecast mentions casttube as a runtime dependency. Included is an initial recipe as well. Signed-off-by: Tom Geelen <t.f.g.geelen@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb b/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb
new file mode 100644
index 0000000000..408dff87bf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-casttube_0.2.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "YouTube Chromecast API"
+HOMEPAGE = "https://github.com/ur1katz/casttube"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "4bb24ba1639d16c8fa367537bf3b88a6"
+SRC_URI[sha256sum] = "f25b3c634efe702896233690f7590e8d6311590910f18dbb763b90419d9ef53c"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-requests \
+"
diff --git a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb b/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
index feae3174a5..618aba4a67 100644
--- a/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pychromecast_13.1.0.bb
@@ -16,4 +16,5 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-requests \
${PYTHON_PN}-protobuf \
${PYTHON_PN}-compression \
+ ${PYTHON_PN}-casttube \
"