aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy Kerr <jk@codeconstruct.com.au>2021-10-26 10:39:50 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-26 10:38:40 -0700
commitd26b5db5c8a6633e8e819902ec84ba939eda7bf5 (patch)
treed43b685f8cc7f454d544b6721f6a16e21b0bf605
parentef9915ca4e82aea332d859d7f89d03eaeb209f83 (diff)
downloadmeta-openembedded-contrib-d26b5db5c8a6633e8e819902ec84ba939eda7bf5.tar.gz
mctp: Add MCTP control utilities
This change adds a recipe for the Management Component Transport Protocol userspace utilities. This contains: - the command-line 'mctp' tool, similar to 'ip', for setting up links, assigning local address and configuring routing. - an optional 'mctpd' daemon, which implements the MCTP control protocol, and manages remote address assignment. The latter depends on systemd (for sdbus), so use a PACKAGECONFIG[systemd] for the conditional service installation. Signed-off-by: Jeremy Kerr <jk@codeconstruct.com.au> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb1
-rw-r--r--meta-networking/recipes-support/mctp/mctp_git.bb31
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
index 8931f412d1..e84086e131 100644
--- a/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
+++ b/meta-networking/recipes-core/packagegroups/packagegroup-meta-networking.bb
@@ -207,6 +207,7 @@ RDEPENDS:packagegroup-meta-networking-support = "\
libtevent \
linux-atm \
lksctp-tools \
+ mctp \
memcached \
ifenslave \
netcat \
diff --git a/meta-networking/recipes-support/mctp/mctp_git.bb b/meta-networking/recipes-support/mctp/mctp_git.bb
new file mode 100644
index 0000000000..cab5d6c132
--- /dev/null
+++ b/meta-networking/recipes-support/mctp/mctp_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Management Component Control Protocol utilities"
+HOMEPAGE = "http://www.github.com/CodeConstruct/mctp"
+SECTION = "net"
+LICENSE = "GPLv2"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4cc91856b08b094b4f406a29dc61db21"
+
+SRCREV = "a8658290b7914f67146a982671b09f2270ba1654"
+
+SRC_URI = "git://github.com/CodeConstruct/mctp;branch=main"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig systemd
+
+PACKAGECONFIG ??= " \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
+"
+
+# mctpd will only be built if pkg-config detects libsystemd; in which case
+# we'll want to declare the dep and install the service.
+PACKAGECONFIG[systemd] = ",,systemd,libsystemd"
+SYSTEMD_SERVICE:${PN} = "mctpd.service"
+
+do_install:append () {
+ if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${S}/conf/mctpd.service \
+ ${D}${systemd_system_unitdir}/mctpd.service
+ fi
+}