aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-10-22 05:11:32 +0800
committerKhem Raj <raj.khem@gmail.com>2021-10-25 08:35:04 -0700
commitba69248dd47157dd335702182037d72531069d44 (patch)
tree64bd2f7691a10dca4a0c78dfc2278ac5b3a3d5b4
parent5f24f662c345640baa90e8feec889f20f74901ba (diff)
downloadmeta-openembedded-contrib-ba69248dd47157dd335702182037d72531069d44.tar.gz
python3-werkzeug: upgrade 2.0.1 -> 2.0.2
Version 2.0.2 ------------- Released 2021-10-05 - Handle multiple tokens in ``Connection`` header when routing WebSocket requests. :issue:`2131` - Set the debugger pin cookie secure flag when on https. :pr:`2150` - Fix type annotation for ``MultiDict.update`` to accept iterable values :pr:`2142` - Prevent double encoding of redirect URL when ``merge_slash=True`` for ``Rule.match``. :issue:`2157` - ``CombinedMultiDict.to_dict`` with ``flat=False`` considers all component dicts when building value lists. :issue:`2189` - ``send_file`` only sets a detected ``Content-Encoding`` if ``as_attachment`` is disabled to avoid browsers saving decompressed ``.tar.gz`` files. :issue:`2149` - Fix type annotations for ``TypeConversionDict.get`` to not return an ``Optional`` value if both ``default`` and ``type`` are not ``None``. :issue:`2169` - Fix type annotation for routing rule factories to accept ``Iterable[RuleFactory]`` instead of ``Iterable[Rule]`` for the ``rules`` parameter. :issue:`2183` - Add missing type annotation for ``FileStorage.__getattr__`` :issue:`2155` - The debugger pin cookie is set with ``SameSite`` set to ``Strict`` instead of ``None`` to be compatible with modern browser security. :issue:`2156` - Type annotations use ``IO[bytes]`` and ``IO[str]`` instead of ``BinaryIO`` and ``TextIO`` for wider type compatibility. :issue:`2130` - Ad-hoc TLS certs are generated with SAN matching CN. :issue:`2158` - Fix memory usage for locals when using Python 3.6 or pre 0.4.17 greenlet versions. :pr:`2212` - Fix type annotation in ``CallbackDict``, because it is not utilizing a bound TypeVar. :issue:`2235` - Fix setting CSP header options on the response. :pr:`2237` - Fix an issue with with the interactive debugger where lines would not expand on click for very long tracebacks. :pr:`2239` - The interactive debugger handles displaying an exception that does not have a traceback, such as from ``ProcessPoolExecutor``. :issue:`2217` Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-werkzeug_2.0.2.bb (renamed from meta-python/recipes-devtools/python/python3-werkzeug_2.0.1.bb)3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-werkzeug_2.0.1.bb b/meta-python/recipes-devtools/python/python3-werkzeug_2.0.2.bb
index 57db204649..4c221cc41f 100644
--- a/meta-python/recipes-devtools/python/python3-werkzeug_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-werkzeug_2.0.2.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
PYPI_PACKAGE = "Werkzeug"
-SRC_URI[sha256sum] = "1de1db30d010ff1af14a009224ec49ab2329ad2cde454c8a708130642d579c42"
+SRC_URI[sha256sum] = "aa2bb6fc8dee8d6c504c0ac1e7f5f7dc5810a9903e793b6f715a9f015bdadb9a"
inherit pypi setuptools3
@@ -35,4 +35,5 @@ RDEPENDS:${PN} += " \
${PYTHON_PN}-threading \
${PYTHON_PN}-unixadmin \
${PYTHON_PN}-misc \
+ ${PYTHON_PN}-profile \
"