aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-25 10:14:41 -0700
committerKhem Raj <raj.khem@gmail.com>2021-10-26 10:05:47 -0700
commit19465da276b06bd70d8c4fcd32e4e52c974b93be (patch)
treeeefa88e74d431f2b2dea2c970406305effb16dd9
parentc2aafe4737043c3b339a0283e9c7060a89bb21e5 (diff)
downloadmeta-openembedded-contrib-19465da276b06bd70d8c4fcd32e4e52c974b93be.tar.gz
gimp: Disable vector icons on mips/rv32 using clang
The infamous segfaults are back when building with clang | make[3]: *** [Makefile:2395: 24/gimp-char-picker.svg] Segmentation fault Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb b/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb
index dbb576a10b..4b0f43b14a 100644
--- a/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb
+++ b/meta-gnome/recipes-gimp/gimp/gimp_2.10.24.bb
@@ -51,6 +51,9 @@ EXTRA_OECONF = "--disable-python \
--disable-check-update \
--without-wmf"
+EXTRA_OECONF:append:toolchain-clang:riscv32 = " --disable-vector-icons"
+EXTRA_OECONF:append:toolchain-clang:mips = " --disable-vector-icons"
+
do_configure:append() {
find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g