aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-06-25 09:51:37 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-15 15:02:28 +0200
commitb5e7302953ee54da8b02246323e89bb5eb4ed87e (patch)
treee3383bdd7fb29945eadc0a7544f92a0fca2d92b6
parent2f1d7533de0dbaf05e6503d23815d201842b1c76 (diff)
downloadmeta-openembedded-contrib-b5e7302953ee54da8b02246323e89bb5eb4ed87e.tar.gz
debianutils: Remove postinstall for some apps.
The mkboot and sensible-* apps have been removed from upstream debianutils. Remove them from the postinstall stages. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=197463 http://en.it-usenet.org/thread/18153/169437/ Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/debianutils/debianutils_4.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/debianutils/debianutils_4.4.bb b/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
index 30dd9a6faf..c93c026538 100644
--- a/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
+++ b/meta-oe/recipes-support/debianutils/debianutils_4.4.bb
@@ -30,7 +30,7 @@ pkg_prerm_${PN} () {
if [ "x$D" != "x" ]; then
echo "can't do u-a offline" ; exit 1
else
- for app in add-shell installkernel mkboot remove-shell run-parts savelog sensible-browser sensible-editor sensible-pager tempfile which ; do
+ for app in add-shell installkernel remove-shell run-parts savelog tempfile which ; do
update-alternatives --remove $app $app.${PN}
done
fi
@@ -40,11 +40,11 @@ pkg_postinst_${PN} () {
if [ "x$D" != "x" ]; then
echo "can't do u-a offline" ; exit 1
else
- for app in add-shell installkernel mkboot remove-shell ; do
+ for app in add-shell installkernel remove-shell ; do
update-alternatives --install ${sbindir}/$app $app $app.${PN} 100
done
- for app in savelog sensible-browser sensible-editor sensible-pager which ; do
+ for app in savelog which ; do
update-alternatives --install ${bindir}/$app $app $app.${PN} 100
done