aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-03 17:39:32 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:33:05 -0800
commitd619965394cd2f0785c4aaf1539cb5fc13efce29 (patch)
tree4eb73048add2da44c041b738228128759e0487a3
parente8f3372ecf58fea9106c9a7782afc4006017274d (diff)
downloadmeta-openembedded-contrib-d619965394cd2f0785c4aaf1539cb5fc13efce29.tar.gz
python-jsonpointer: add a python3 version of the recipe
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpointer.inc14
-rw-r--r--meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb13
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb2
3 files changed, 18 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer.inc b/meta-python/recipes-devtools/python/python-jsonpointer.inc
new file mode 100644
index 0000000000..e678198cc4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-jsonpointer.inc
@@ -0,0 +1,14 @@
+SUMMARY = "Resolve JSON Pointers in Python"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi
+
+SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b"
+SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-re \
+"
diff --git a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
index 96b71e3bd8..064bd6c5da 100644
--- a/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
+++ b/meta-python/recipes-devtools/python/python-jsonpointer_1.14.bb
@@ -1,11 +1,2 @@
-SUMMARY = "Resolve JSON Pointers in Python"
-HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
-
-inherit pypi setuptools
-
-SRC_URI[md5sum] = "190aeb8afcb0efddfe831a4e533e163b"
-SRC_URI[sha256sum] = "c681af823545c731b7b38aedd5d4eee4c5eff87bc0f25e0ff25444a4189eac4d"
-
-RDEPENDS_${PN} += "python-re python-json"
+inherit setuptools
+require python-jsonpointer.inc
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb
new file mode 100644
index 0000000000..8d0a09b432
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonpointer_1.14.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-jsonpointer.inc