aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <TicoTimo@gmail.com>2014-07-05 11:16:40 -0700
committerTim Orling <TicoTimo@gmail.com>2014-08-24 19:45:16 -0700
commit954113f7d4b17530baec3d3ca5c3656b7e2ba0a6 (patch)
tree6d4504b8361be92d0cd94f81f9d0382f1836d314
parent662682c75c8a920a8486343e6c3d5f373e19b65b (diff)
downloadmeta-openembedded-contrib-954113f7d4b17530baec3d3ca5c3656b7e2ba0a6.tar.gz
libextutils-parsexs-perl: add 3.24
Signed-off-by: Tim Orling <TicoTimo@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb b/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb
new file mode 100644
index 0000000000..3991d5cc14
--- /dev/null
+++ b/meta-perl/recipes-perl/libextutils/libextutils-parsexs-perl_3.24.bb
@@ -0,0 +1,45 @@
+SUMMARY = "ExtUtils::ParseXS - converts Perl XS code into C code"
+DESCRIPTION = "\"ExtUtils::ParseXS\" will compile XS code into C code by \
+embedding the constructs necessary to let C functions manipulate Perl \
+values and creates the glue necessary to let Perl access those functions. \
+The compiler uses typesmapes to determine how to map C function parameters \
+and variables to Perl values."
+
+SECTION = "libs"
+
+HOMEPAGE = "http://metapan.org/release/ExtUtils-ParseXS/"
+
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+LIC_FILES_CHKSUM = "file://README;beginline=121;endline=130;md5=10ddb3a673b4c732022ac899968ea9cc"
+
+SRC_URI = "${CPAN_MIRROR}/authors/id/S/SM/SMUELLER/ExtUtils-ParseXS-${PV}.tar.gz"
+SRC_URI[md5sum] = "e6be3f1d493e04ed805576104cf4328b"
+SRC_URI[sha256sum] = "30b60b8208fc9b7746ed934b678bb9618a8f28994dae8774548353a7b550371e"
+
+S = "${WORKDIR}/ExtUtils-ParseXS-${PV}"
+
+inherit cpan
+
+RDEPENDS_${PN} = " libextutils-makemaker-perl \
+ perl-module-carp \
+ perl-module-cwd \
+ perl-module-dynaloader \
+ perl-module-extutils-cbuilder \
+ perl-module-file-basename \
+ perl-module-file-spec \
+ perl-module-symbol \
+ perl-module-test-more \
+"
+
+RPROVIDES_${PN} += " libextutils-parsexs-constants-perl \
+ libextutils-parsexs-countlines-perl \
+ libextutils-parsexs-eval-perl \
+ libextutils-parsexs-utilities-perl \
+ libextutils-typemaps-perl \
+ libextutils-typemaps-cmd-perl \
+ libextutils-typemaps-inputmap-perl \
+ libextutils-typemaps-outputmap-perl \
+ libextutils-typemaps-type-perl \
+"
+
+BBCLASSEXTEND = "native"